Slow Page loading, momentarily pauses audio output in different tab

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
7 months ago
6 months ago

People

(Reporter: alex.farlie, Unassigned)

Tracking

({regression})

67 Branch
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 unaffected, firefox66 unaffected, firefox67 affected)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Loaded a you tube clip and started playback: https://www.youtube.com/watch?v=WbV7frdhYic

Then opened in a new tab - https://www.mozilla.org/en-US/firefox/67.0a1/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew

Actual results:

When the second page paused during loading, the audio output from the You Tube clip momentarily paused ( a click) in the audio. Refreshing the page caused the same click.

Expected results:

The audio playback from the YouTube clip should have been continuous regardless of the status of other parts of the browser.

OS: Unspecified → Windows 7
Hardware: Unspecified → x86

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0
Build ID: 20190208095514

Hi Alex,

Thank you for taking the time to report this.
I was able to reproduce the issue that you have described only on Windows 7, on the latest Nightly build.

I could not reproduce it on DevEdition or Release builds on Windows 7. Also, I was not able to reproduce it on any build (including the Nightly build) on Windows 10, Ubuntu 16.04 or Mac OSX.

Running Mozregression, indicated that this behavior may have started to reproduce after the fix for https://bugzilla.mozilla.org/show_bug.cgi?id=1476981 - Turn on dom.ipc.processPriorityManager.enabled in Nightly (from pushlog - https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ba41803aea537cac4ce379b1935ec4cdb6f76185&tochange=015cdc788e05a9dafc0abe737c9d16153f607b4c).

I am going to assign this to Core: Audio/Video component for a mode advised input. If this is not the proper component for this report, please feel free to reassign it.

Status: UNCONFIRMED → NEW
Component: Untriaged → Audio/Video
Ever confirmed: true
Product: Firefox → Core

Additional information:- "dom.ipc.processPriorityManager.enabled" is set to true for me. I'll run a test with it switched off.

As you indicate that this isn't present in a developer release, it may resolve on it's own given that some aspects of the Firefox's internal architecture are about to change ( To do with isolating certain media on pages even more tightly IIRC.)

Running with the relevant option disabled seemed to temporarily solve the problem..

Blocks: 1476981
Component: Audio/Video → DOM: Content Processes
Depends on: 1523974
Duplicate of this bug: 1526869

A patch landed recently that makes audio-playing background tabs go into the "normal" process priority bucket. Are you able to reproduce in a recent Nightly with "dom.ipc.processPriorityManager.enabled" reset to the default?

Flags: needinfo?(alex.farlie)

Not seeing the pausing or disruption in audio output on the current nightly release. I will wait a few days for others to check as well before considering this definitive though.

Flags: needinfo?(alex.farlie)

(In reply to Mike Conley (:mconley) (:⚙️) from comment #5)

A patch landed recently that makes audio-playing background tabs go into the
"normal" process priority bucket. Are you able to reproduce in a recent
Nightly with "dom.ipc.processPriorityManager.enabled" reset to the default?

Maybe we should detect background tabs that are consuming media and not lower the priority. People often play music in background tabs, if this is getting in the way of that it seems pretty serious.

Flags: needinfo?(mconley)

(In reply to alex.farlie from comment #6)

Not seeing the pausing or disruption in audio output on the current nightly
release. I will wait a few days for others to check as well before
considering this definitive though.

Sorry, I see we did what I suggested and it fixed the issue. Closing this out.

Status: NEW → RESOLVED
Closed: 6 months ago
Flags: needinfo?(mconley)
Resolution: --- → WORKSFORME

Considering this resolved, but I am seeing tiny delays in audio output on the most recent "67.0a1 (2019-02-26) (32-bit)" nightly in relation to Soundcloud playback, but as I've had this for a long time, I am suspecting an audio driver issue on my system.

You need to log in before you can comment on or make changes to this bug.