Closed Bug 1525173 Opened 10 months ago Closed 8 months ago

[about:addons] Convert detail view to HTML

Categories

(Toolkit :: Add-ons Manager, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox67 --- wontfix
firefox68 --- verified

People

(Reporter: mstriemer, Assigned: mstriemer)

References

(Blocks 1 open bug)

Details

(Whiteboard: [feature-scope])

Attachments

(2 files, 1 obsolete file)

The detail view should be converted to HTML. The new mocks [1] treat this as an expanded card in the list view (this could pose problems in the interim HTML in XUL state). There are a few things to do, which could be split into smaller bugs:

  • List the details for the extension
    • Name, description, update date, install date, version
    • Author, homepage, rating, contribute page (with link)
  • Manage Add-on Manager settings
    • Private browsing
    • Update policy
  • Manage extension settings
    • Link to open external page
    • Embed inline preferences
  • Disable/Remove actions

[1] https://mozilla.invisionapp.com/share/W2DW6NYX9#/screens/256825108

Whiteboard: [feature-scope]
Depends on: 1532724
Depends on: 1532726
Depends on: 1531967
Blocks: 1533795
No longer blocks: 1505924
Priority: P2 → P1
Assignee: nobody → mstriemer
Depends on: 1535683
Summary: Convert detail view to HTML → [about:addons] Convert detail view to HTML
Attachment #9053009 - Attachment is obsolete: true
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c47de582c326
HTML about:addons detail view r=jaws,flod
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Attached image Bug1525173.png

This issue is verified as fixed on Firefox 68.0a1 (20190409221047) under Win 7 64-bit and Mac OS X 10.14.1.

Please see the attached screenshot.

Status: RESOLVED → VERIFIED
Depends on: 1544824
Duplicate of this bug: 1542794
No longer depends on: 1532726
No longer depends on: 1535683
No longer depends on: 1531967
No longer depends on: 1532724
No longer depends on: 1544824
You need to log in before you can comment on or make changes to this bug.