Remove the pres context pointer from ComputedStyle.

RESOLVED FIXED in Firefox 67

Status

()

enhancement
P3
normal
RESOLVED FIXED
5 months ago
4 months ago

People

(Reporter: emilio, Assigned: emilio)

Tracking

(Blocks 1 bug)

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(4 attachments)

Move it to the frame instead.

Assignee

Updated

5 months ago
Assignee: nobody → emilio
Priority: -- → P3
Assignee

Comment 3

5 months ago

Depends on D18734

Assignee

Comment 4

5 months ago

Now that there's no ArenaRefPtr, the styles aren't cleared when the shell goes
away (due to an iframe becoming display: none or what not). This caused a few
very confusing failures in test_initial_computation:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=c2746a05ce7b20759a820d6f26a55a3200d8e6b8&selectedJob=226267113

Which holds on to a reference of a style on a display: none iframe1, reframes
it periodically2, exposing this bug.

For now, keep the id of the shell we got the style from around. When we support
computing styles in display: none iframes this may need more work, but that's
out of the scope of this bug.

Depends on D18735

Comment 5

5 months ago
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/c944db09eff5
Kill ComputedStyle::ComputedData. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/525e804dc7e6
Kill ComputedStyle::mPresContext, move the pointer to the frame instead. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/56eeff69792c
Remove ArenaRefPtr. r=jwatt
https://hg.mozilla.org/integration/autoland/rev/d9be4af74c4b
Fix a very subtle invalidation bug exposed by test_initial_computation.html. r=jwatt

Comment 6

5 months ago
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/c90fe3ee1999
followup: fix rusttests to reopen the CLOSED TREE.
Assignee

Updated

5 months ago
Blocks: 1525955
Assignee

Updated

4 months ago
Duplicate of this bug: 1448535
You need to log in before you can comment on or make changes to this bug.