Closed Bug 1525588 Opened 1 year ago Closed 1 year ago

2019-02-06 ARM64 Windows build won't start

Categories

(Core :: General, defect)

ARM64
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla67
Tracking Status
firefox66 --- verified
firefox67 --- verified

People

(Reporter: overholt, Assigned: tjr)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

I can reliably reproduce with either an installation of the latest nightly (today's) or upgrading to it.

STR

Expected

  • just works.

Actual

  • I see 2 processes start up in Task Manager but never get my main window.

nbp (CCd) reported the same experience. I think we're both on Lenovo Yoga C630 devices.

Wonder if it's related to bug 1485016.

Flags: needinfo?(dmajor)

FWIW I can start the 2019-02-06 build on x86_64 Windows 10.

I expect this was me and I will cook up a patch and confirm with overholt

Flags: needinfo?(dmajor)
Summary: 2019-09-06 ARM64 Windows build won't start → 2019-02-06 ARM64 Windows build won't start

We're hitting ntdll!LdrpHandleInvalidUserCallTarget on:

xul!std::sys::windows::thread_local::on_tls_callback [/rustc/9fda7c2237db910e41d6a712e9a2139b352e558b/src\libstd\sys\windows\thread_local.rs @ 211]:

This happens during ntdll!LdrpCallTlsInitializers within the loading of libxul.

Maybe we don't have a CFG story for rust code? I wonder why this isn't a problem on x86_64.

Blocks: 1485016

So the dispatch-function thing may be a red herring; Microsoft's own DLLs don't have one either.

I'll continue to look at it but at this point it's not looking like I'm going to come up with a quick fix. We should probably disable CFG on arm64 for the time being. Maybe even land directly on m-c.

OK, so I found that xul!std::sys::windows::thread_local::on_tls_callback is on the approved targets list on x86_64 (it doesn't resolve by name so I had to look it up by address) but not on aarch64.

Comment on attachment 9041850 [details] [diff] [review]
Bug 1525588 - Do not enable CFG on ARM builds, as it causes undiagnosed failures r?dmajor

Let's use target.cpu instead of CONFIG.
Attachment #9041850 - Flags: review?(dmajor)
Attachment #9041858 - Flags: review?(dmajor) → review+

Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ea669e7b7e93
Do not enable CFG on ARM builds, as it causes undiagnosed failures. r=dmajor

Keywords: checkin-needed

Sorry, didn't see this is duplicated in bug 1525806. There's a WER file attached there, but let me know if you need more.

Duplicate of this bug: 1525806
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Duplicate of this bug: 1526256
Duplicate of this bug: 1526250
Duplicate of this bug: 1526256

Comment on attachment 9041858 [details] [diff] [review]
Bug 1525588 - Do not enable CFG on ARM builds, as it causes undiagnosed failures r?dmajor

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

None

User impact if declined

Necessary if Bug 1485016 is uplifted

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

It's disabling the feature for ARM builds.

String changes made/needed

Attachment #9041858 - Flags: approval-mozilla-beta?
Comment on attachment 9041858 [details] [diff] [review]
Bug 1525588 - Do not enable CFG on ARM builds, as it causes undiagnosed failures r?dmajor

OK for beta uplift - please land the patch in bug 1523003 first, then the patch in bug 1485016, then this patch in bug 1525588.
Attachment #9041858 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I can confirm the verification of the issue in firefox67 since the Aarch64 build starts and runs properly on Lenovo Yoga C630-13Q50 with Windows 10 Home (v1803). Verified using: Nightly v67.0a1 (2019-02-11) (64-bit) (Aarch64 build)
There isn't any build for beta yet, so I will leave the general status as before.
Thank you.

Status: RESOLVED → VERIFIED

problem was back for me today. i ran the nightly updater but firefox failed to restart.
to fix:

  • i downloaded latest aarch64 nightly installer and ran a fresh install
  • i ran "c:\Program Files\Firefox Nightly\firefox.exe" -p and deleted my one and only profile, then created a new profile, firefox still wouldn't run
  • i found a bunch of firefox processes running in task manager and killed them all
  • i deleted the contents of %APPDATA%\Mozilla\Firefox\Profiles (there were two profile folders present)
  • i created a new default profile

firefox started after this.

If the browser starts at all, even if it takes considerable gymnastics, then it would have to be a different issue from the one tackled here: the nature of the CFG bug would have prevented you from being able to launch ever. It would be better to track the new issue as a separate bug. (FWIW I couldn't reproduce it just now)

Rob, can you please log a different issue for this? please specify the exact build you used. Thanks.

Flags: needinfo?(rthijssen)

(In reply to Bodea Daniel [:danibodea] from comment #25)

Rob, can you please log a different issue for this? please specify the exact build you used. Thanks.

i suspect that if my issue was not related to this bug, then it was just a quirk of my system setup. the fact that there were running firefox processes in the background might have prevented the profile manager from completely deleting a running profile and may have been what prevented firefox from starting after the clean install.

i initially commented above as a result of googling for a solution for firefox not restarting when i hit the update button and arriving at this and other aarch64 specific bugs. i don't think i have a new issue to report. my comment was just to help people who arrived here looking for a way to get ff working again if they happen to be in the same situation of having some running ff processes in the background.

apologies for causing confusion on this bug.

Flags: needinfo?(rthijssen)
You need to log in before you can comment on or make changes to this bug.