Hide Top Sites section instead of showing blank set of Top Sites icons on new tab page

RESOLVED DUPLICATE of bug 1533601

Status

()

defect
P2
normal
RESOLVED DUPLICATE of bug 1533601
6 months ago
2 months ago

People

(Reporter: mconca, Unassigned)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 wontfix, firefox67 affected)

Details

Attachments

(1 attachment)

Posted image screenshot.png

My new tab page was set to only show Pocket stories and snippets (search, top sites, highlights were disabled).

I updated Nightly and now my new tab page shows a row for Top Sites above the Pocket stories, but the Top Sites icons are all blank. See attached picture.

What should happen if the user has turned off top sites? Ignore the old preference? Remove the section? The latter might cause layout issues if we're expecting columns to be a certain height.

Flags: needinfo?(wkonu)

We can avoid uplift / problems with the 66 experiments if we target the experiment to users who have browser.newtabpage.activity-stream.feeds.topsites set to true.

We're targeting users who are using the default new tab/home settings, so users who have turned off top sites won't be in our experiment.

Flags: needinfo?(wkonu)

There's still the question of what the expected behavior should be.

If we're users who have browser.newtabpage.activity-stream.feeds.topsites set to true, doesn't this resolve the issue?

What's the expected behavior for 67 or whenever it's not an experiment?

Blocks: 1512725
Keywords: uiwanted

If a user has turned off Top Sites and is not in the experiment, the Top Sites section should not appear on their Home/New Tab

Iteration: --- → 67.3 - Feb 25 - Mar 10
Priority: -- → P2
Priority: P2 → P1
Iteration: 67.3 - Feb 25 - Mar 10 → 68.1 - Mar 18 - 31
Keywords: uiwanted
Priority: P1 → P2

We are working on getting about:preferences working fluidly with the Pocket newtab for 68. I am going to close this and apologize to Nightly users for the slightly wonky experience

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1532460

The plan for 68 seems to be restoring the preference view to turn off top sites:

https://www.figma.com/file/VHWnhbRjZKLUt1ZNplZ7Zwwl/Home%2FNew-Tab-Explorations?node-id=7%3A1

Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: Blank set of Top Sites icons on new tab page → Hide Top Sites section instead of showing blank set of Top Sites icons on new tab page
Iteration: 68.1 - Mar 18 - 31 → 68.2 - Apr 1 - 14
Blocks: 1533601
No longer blocks: 1512725

Looks like this is being addressed as part of bug 1533601

Status: REOPENED → RESOLVED
Closed: 6 months ago4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1533601
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.