Closed Bug 1529340 Opened 3 years ago Closed 3 years ago

CFR Pinned tabs popup animation

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 67
Iteration:
67.3 - Feb 25 - Mar 10
Tracking Status
firefox66 --- wontfix
firefox67 --- fixed

People

(Reporter: andreio, Assigned: rrosario)

References

Details

(Keywords: github-merged)

Attachments

(6 files)

The animation should loop by default.
When you click the pause button the animation should be replaced with a static asset (some frame of the animation).
When you click the resume button the animation should start to loop again.

I think toolkit.cosmeticAnimations.enabled is meant to disable all animations in the browser. We should respect this preference for the animation in our dropdown.

Severity: normal → enhancement
Iteration: --- → 67.3 - Feb 25 - Mar 10
Priority: -- → P1

Amy is going to provide the assets required.

Flags: needinfo?(amlee)
Assignee: nobody → rrosario
Attached image pinned_tab-apng.png
Flags: needinfo?(amlee)
Attached image play icon.svg
Attached image pause icon.svg

We are still missing the static image that shows up when the user hits pause. Amy or Andrei, does this exist already?

Also, the play/pause need a different color in dark theme. Those can probably be set with CSS but we need the color value.

Flags: needinfo?(andrei.br92)
Flags: needinfo?(amlee)

In the Feb 20 meeting (CFR crossfunctional) notes, it says we decided to: Loop, and then replace with static image once paused.

We don't need to implement the play part after the user pauses. I think the reasoning was that users will only hit pause if the animation is bugging them so there is no reason to provide the ability to restart.

(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #6)

We are still missing the static image that shows up when the user hits pause. Amy or Andrei, does this exist already?

Also, the play/pause need a different color in dark theme. Those can probably be set with CSS but we need the color value.

Oh, and can we get an animated PNG in the right dimensions? It looks like the width allocated in the doorhanger is about 310-315px.

Attached image recommend_icon.svg
Flags: needinfo?(andrei.br92)

I have all the assets now. Clearing the NI

Flags: needinfo?(amlee)

MozReview-Commit-ID: FTr5Pi7ySbY

Pushed by rrosario@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b52eb25bbe9c
CFR Pinned tabs popup animation r=k88hudson
Pushed by rrosario@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6a3b22130b99
CFR Pinned tabs popup animation r=k88hudson
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Depends on: 1533662
Blocks: 1533832
Flags: needinfo?(rrosario)
Blocks: 1534444
Component: Activity Streams: Newtab → Messaging System
No longer depends on: 1533662
Regressions: 1533662
You need to log in before you can comment on or make changes to this bug.