Closed Bug 1529345 Opened 6 months ago Closed 2 months ago

Implement Gecko event breakpoint notification infrastructure and expose via IDL interface

Categories

(DevTools :: Debugger, enhancement, P2)

enhancement

Tracking

(firefox69 fixed)

RESOLVED FIXED
Firefox 69
Tracking Status
firefox69 --- fixed

People

(Reporter: loganfsmyth, Assigned: loganfsmyth)

References

(Blocks 1 open bug)

Details

(Whiteboard: [debugger-mvp])

Attachments

(2 files)

We want a JS API to allow the debugger server to register a callback that will be called just before and just after Gecko dispatches a DOM event.

The plan at the moment is an API like

ChromeUtils.getDebuggerNotifier(globalObj).addDOMEventListener((evt, preOrPost) => {

});
Priority: P1 → P2
Whiteboard: [debugger-mvp]

Can we find a better place for this to live than dom/base? Was a new subdirectory considered?

@bz Absolutely. That was one of my outstanding questions on this. I'd be 100% for putting these in a subdirectory. Would dom/debugger be reasonable?

Works for me. Peter, any objections?

Flags: needinfo?(peterv)
Attachment #9063906 - Attachment description: Bug 1529345 - Add Gecko infrastructure for receiving notifications about debugger-related events. → Bug 1529345 - Part 2: Add Gecko infrastructure for receiving notifications about debugger-related events.

Sure, dom/debugger is fine by me.

Flags: needinfo?(peterv)
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Pushed by lsmyth@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/15bac42cc73a
Part 1: Handle some missing includes. r=jimb
https://hg.mozilla.org/integration/autoland/rev/63f80a49839e
Part 2: Add Gecko infrastructure for receiving notifications about debugger-related events. r=jimb,smaug
Pushed by lsmyth@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cf6f6281cb44
Part 1: Handle some missing includes. r=jimb
https://hg.mozilla.org/integration/autoland/rev/87aa4894b4a1
Part 2: Add Gecko infrastructure for receiving notifications about debugger-related events. r=jimb,smaug
Flags: needinfo?(lsmyth)
Pushed by lsmyth@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2cd3642e0943
Part 1: Handle some missing includes. r=jimb
https://hg.mozilla.org/integration/autoland/rev/e074fcc399d1
Part 2: Add Gecko infrastructure for receiving notifications about debugger-related events. r=jimb,smaug
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Regressions: 1554570
No longer regressions: 1554570
You need to log in before you can comment on or make changes to this bug.