Closed Bug 1526082 (dbg-event-bps-m1) Opened 2 years ago Closed 1 year ago

[meta] Debugger Event Breakpoints M1

Categories

(DevTools :: Debugger, task, P3)

69 Branch
task

Tracking

(relnote-firefox 71+)

RESOLVED FIXED
Firefox 69
Tracking Status
relnote-firefox --- 71+

People

(Reporter: Harald, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: meta)

Tracks work for implementing a new Event Breakpoints panel in the Debugger.

Severity: normal → enhancement
Priority: -- → P1
Duplicate of this bug: 1528416
Depends on: 1529345
Summary: [meta] Event Breakpoints, Milestone 1: Debugger Panel → [meta] Debugger Event Breakpoints M1
Depends on: 1531874
Priority: P1 → --
Priority: -- → P2
Alias: event-breakpoints-m1 → dbg-event-bps
Depends on: 1550821
Alias: dbg-event-bps → dbg-event-bps-m1

We should make sure that we show anonymous events listeners CC bug 1326816

STR_1:
1. Open url   data:text/html,<script>eval("onclick=function(e){console.log(e)}")</script>
3. Open devtools -> debugger -> events

AR:  No event listeners listed
ER: 'click' event listener should be listed

Depends on: 1326816

We should make sure that we show anonymous events listeners CC bug 1326816

Just to avoid any confusion: M1 does not list any event handlers or touch the event bubble in Inspector. M1's panel will only show types of events to pause on – but not active handlers (like the old debugger).

Duplicate of this bug: 1327716
Type: enhancement → task
Depends on: 1557782
Depends on: 1557784
Depends on: 1560568
Depends on: 1560942
Depends on: 1566283
Priority: P2 → P3
No longer depends on: 1550821

Release Note Request (optional, but appreciated)
[Why is this notable]: Top user feedback
[Affects Firefox for Android]: No
[Suggested wording]: DevTools new Event Listener Breakpoints let you debug which code a page executes in response to browser events. You can pick specific types, such as click or keydown, or whole categories of events, like all mouse input.
[Links (documentation, blog post, etc)]: https://developer.mozilla.org/en-US/docs/Tools/Debugger/Set_event_listener_breakpoints

Status: NEW → RESOLVED
Closed: 1 year ago
relnote-firefox: --- → ?
Resolution: --- → FIXED
Target Milestone: Firefox 67 → Firefox 70
Version: 67 Branch → 70 Branch
Target Milestone: Firefox 70 → Firefox 69
Version: 70 Branch → 69 Branch

This is mentioned in the draft notes for 71.

You need to log in before you can comment on or make changes to this bug.