Closed Bug 1529983 Opened 10 months ago Closed 8 months ago

[Context Menu] In Pocket New Tab handle edge cases when there are no stories to show

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 68
Iteration:
68.2 - Apr 1 - 14
Tracking Status
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- verified

People

(Reporter: pdahiya, Assigned: pdahiya)

References

Details

(Keywords: github-merged)

Attachments

(1 file)

With Pocket New Tab supporting dismiss individual story, we should handle edge cases
a) Show placeholder when there is no story to show
b) Show a message when all stories are dismissed

Blocks: 1512725
Depends on: 1527642
Severity: normal → enhancement
Iteration: --- → 67.3 - Feb 25 - Mar 10
Priority: -- → P1

Scope of this bug is to handle edge cases stemming from dismiss individual story. NI Wolasi to double check that these edge cases are not needed for experiments and safe to move to 68 release.

Flags: needinfo?(wkonu)

For this bug we should cover the first edge case i.e. showing a placeholder when a story is dismissed and there are no stories to replace it…

Expected Behavior
When a story is dismissed, if now new stories are available, the dismissed story should be replaced by a placeholder.

The place holder should have the same dimensions as the story it replaced.

Spec
https://www.figma.com/file/HAk87Z6QBcu6YxBIoXN6LJcU/Firefox-Home-Components?node-id=1313%3A0

For QA
Linked below is an example of placeholders for Top Sites and some content components
https://www.figma.com/file/RizUfWdXDzKX3dH5Skz8XEUy/Layouts-for-QA?node-id=1%3A2

Implementation Note
Dark theme should be supported

Flags: needinfo?(wkonu)
Summary: In Pocket New Tab handle edge cases when there are no stories to show → [Context Menu] In Pocket New Tab handle edge cases when there are no stories to show
Iteration: 67.3 - Feb 25 - Mar 10 → 68.1 - Mar 18 - 31
Assignee: nobody → pdahiya
Iteration: 68.1 - Mar 18 - 31 → 68.2 - Apr 1 - 14
No longer blocks: 1512725
Duplicate of this bug: 1536812

Once all stories have been dismissed a message should be displayed telling the user to check again later for new stories.

Spec
https://www.figma.com/file/0xZkmT86rSXbGRB4eIvrn0ts/New-Tab-Spec-for-Fx-v68?node-id=91%3A12

(In reply to Wolasi from comment #4)

Once all stories have been dismissed a message should be displayed telling the user to check again later for new stories.

Spec
https://www.figma.com/file/0xZkmT86rSXbGRB4eIvrn0ts/New-Tab-Spec-for-Fx-v68?node-id=91%3A12

what happens if there are no stories to show under multiple components e.g. Health and Fitness in attached spec, do we show message for each component?

Flags: needinfo?(wkonu)

Yes, let's show the message for each component

Flags: needinfo?(wkonu)
Keywords: github-merged
Blocks: 1543756
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

I have verified this issue with the latest Firefox Nightly (68.0a1 Build ID - 20190414214746) installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. Now, if no new stories are available, the dismissed story is replaced by a placeholder. Also if all the Pocket cards are dismissed, a placeholder message is displayed.

Status: RESOLVED → VERIFIED
Blocks: 1556862
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.