Closed Bug 1527642 Opened 10 months ago Closed 9 months ago

[Context Menu] Redesigned new-tab page should display context menu button for all discovery stream layouts

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 67
Iteration:
67.3 - Feb 25 - Mar 10
Tracking Status
firefox66 --- wontfix
firefox67 --- verified
firefox68 --- verified

People

(Reporter: dholbert, Assigned: pdahiya)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged, uiwanted)

User Story

User Story captured in doc below:
https://docs.google.com/document/d/13lNdQdVdXv7ueEnU0dp9NyYWmI21b5-1nFN3aayrr7I/edit?usp=sharing

STR:

  1. Open a new tab.

  2. Decide that one of the 3 "Recommended by Pocket" stories isn't something you want to be looking at. (Perhaps it's politically/emotionally charged, or it's a sponsored story for something that doesn't interest you, or it's just not your thing.)

  3. See if you can dismiss that story to make your new-tab page feel more friendly/tailored-to-your-needs.

ACTUAL RESULTS:
As far as I can tell, there's no way to dismiss individual stories right now, after the redesign that was preffed on in bug 1523703. (They used to be dismissable via a hover menu, in the previously shipping design of this page, but the hover menu doesn't show up anymore.)

EXPECTED RESULTS:
We should still allow users to dismiss individual suggestions.

I believe this is intentional with the plan of showing a lot more content than just the 3 of the current "basic" endpoint.

Flags: needinfo?(wkonu)

Yes, this omission is intentional for the first phase of New Tab experiments

Flags: needinfo?(wkonu)
Severity: normal → enhancement
Iteration: --- → 67.3 - Feb 25 - Mar 10
Priority: -- → P1
Keywords: uiwanted
Duplicate of this bug: 1527500
Summary: Redesigned new-tab page doesn't have an option to dismiss individual "Recommended by Pocket" stories → Redesigned new-tab page should have menu option to dismiss and save to pocket individual story
Blocks: 1529983
Assignee: nobody → pdahiya
User Story: (updated)

Setting NI for Wolasi to updated user story doc with designs. Thanks!

Flags: needinfo?(wkonu)

Specs have been linked to in user story doc, and linking here for posterity https://www.figma.com/file/HAk87Z6QBcu6YxBIoXN6LJcU/Firefox-Home-Components?node-id=1309%3A118

Flags: needinfo?(wkonu)

Decided to break implementing 'Bookmark', 'Save to Pocket', 'dismiss' context menu options for Pocket New Tab in its own separate bugs considering the complexity of landing all these features together. Here are the recommended steps

  • This bug brings in context menu button for Pocket New Tab with options 'Open in a New Window', 'Open in a New Private Window'. Scope of this bug will be to handle styles and display of context menu inside different layouts of pocket new tab.

  • Implement dismiss a story menu option inside context menu

  • Reopen bug 1527500 to implement 'Save to Pocket' menu option

  • Implement bookmark menu option inside pocket new tab context menu

Blocks: 1527500
Summary: Redesigned new-tab page should have menu option to dismiss and save to pocket individual story → Redesigned new-tab page should display context menu button for all discovery stream layouts
Blocks: 1531585
Blocks: 1531587
Summary: Redesigned new-tab page should display context menu button for all discovery stream layouts → [Context Menu] Redesigned new-tab page should display context menu button for all discovery stream layouts
Blocks: 1531596
Blocks: 1533832
Status: NEW → RESOLVED
Closed: 9 months ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

I have verified this issue with the latest Firefox Beta (67.0b9 Build ID - 20190408123043) and with the latest Firefox Nightly (68.0a1 Build ID - 20190410215612) installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. Now, the context menu button is displayed when hovering a "Recommended by Pocket" card.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.