[Search Quantumbar] Releasing the shift key doesn't reactivate the switch to tab option in search suggestions

RESOLVED FIXED in Firefox 67

Status

()

defect
P1
normal
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: laszlo.bialis, Assigned: mak)

Tracking

(Blocks 2 bugs)

Trunk
Firefox 67
Unspecified
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67 unaffected)

Details

Attachments

(1 attachment)

Reporter

Description

3 months ago

Note

  • Make sure "browser.urlbar.quantumbar" is set to "true" in about:config

Affected versions

  • Nightly 67.0a1

Affected platforms

  • Only Windows, tried on Win10 & Win7 x64
    macOS 10.14 and Ubuntu 16.04 don't reproduce this issue

Steps to reproduce

  1. Launch Firefox
  2. Search for ex: youtube from the URL bar
  3. Leave the tab with the search results open
  4. Open a new tab and search again for youtube
  5. After the search suggestions are displayed check for the "Switch to tab" suggestion
  6. Press and release Shift key

Expected result

  • When Shift key is pressed the "Switch to tab" suggestion should disappear, instead a link should be displayed. After Shift key is released the "Switch to tab" suggestion should be displayed again.

Actual result

  • After releasing the Shift key the "Switch to tab" suggestion is not displayed anymore, as the key would remain pressed. Pressing the Shift key several times again would not change this behavior, only open the Sticky Keys popup. Even if one selects not to activate Sticky Keys from the popup, the "Switch to tab" suggestion wouldn't be shown again.

Additional notes

  • I've reproduced this issue every time on a regularly used profile, with rich history.
  • On a new profile however the issue is reproduced intermittently, only after several tries with the press and release Shift key combination I've managed to reproduce it.
Reporter

Updated

3 months ago
OS: Unspecified → Windows
Assignee

Comment 1

3 months ago

I cannot directly reproduce the bug with the given steps... but I think I know what's up. Basically the Event Bufferer delays the events, but we use those events to track override keys like SHIFT. If a keydown is delayed, the keyup may happen before it is replayed. The old implementation didn't suffer this problem because it was delaying keypress and using keydown to track override keys.

Assignee: nobody → mak77
Status: NEW → ASSIGNED
Priority: -- → P1
Assignee

Comment 2

3 months ago

I'll have to change the way the EventBufferer hooks into input.

Assignee

Comment 3

3 months ago

And the other problem is that on Windows the keydown event gets repeated if you keep the button pressed, other platforms may differ. Thus we can't just use a counter.

Assignee

Updated

3 months ago
See Also: → 1507755
Assignee

Comment 4

3 months ago

This fixes 2 problems causing overrides (with SHIFT/ALT/CTRL) to stick longer than expected:

  1. The event bufferer may delay keydown, keyup could then happen before it
  2. On some platforms holding a key generates multiple events, so there's no match in number of keydown/keyup
Assignee

Updated

3 months ago
Blocks: 1531737

Comment 5

3 months ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/d9e6f5d564be
Properly handle actions overrides in the Quantum Bar. r=dao

Comment 6

3 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
You need to log in before you can comment on or make changes to this bug.