[fuzzy] Provide a way to intersect command line queries

RESOLVED FIXED in Firefox 67

Status

enhancement
RESOLVED FIXED
5 months ago
4 months ago

People

(Reporter: ahal, Assigned: ahal)

Tracking

unspecified
mozilla67
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(2 attachments)

Currently when you specify --query on the command line, the results of that query will be union'ed with the results in the finder (or the results that were loaded from a preset).

However, sometimes we want to take the intersection of the initial set of tasks + the tasks matched by --query. This is especially useful when using presets, e.g:

$ ./mach try --preset perf -q "windows"

This command line would select all perf tasks + all windows tasks (as opposed to all windows perf tasks). The latter is likely what developers will want more often than not, but it is not currently possible.

There are a few options here:

A) A try syntax-like --and argument that changes queries to intersection:

$ ./mach try --preset perf --and -q "windows"

B) A separate cli argument:

$ ./mach try --preset perf --xquery "windows"

C) A modifier within the query itself:

$ ./mach try --preset perf -q "x:windows"

After some discussion on irc, I think option A will be the least confusing as it is consistent with try syntax and doesn't allow complex invocations that have both unions and intersections in them.

I plan on making the cli -x/--and so that we can also use something like:

$ ./mach try --preset perf -xq "windows"

There's a risk to this though, if people forget the -x it will result in a a lot of tasks being run. Which leads to option:

D) Make --and the default when using presets. This seems too magical and confusing though, but at least eliminates the risk of forgetting to specify -x :/.

Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cd1704c276df
[fuzzy] Add ability to intersect queries, r=jgraham
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Blocks: 1533770
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/482fe5ca8245
[try] Add a 'perf' preset for selecting raptor and talos tasks, r=rwood

Oops, I had originally created that 'perf' patch as a series on this one, then forgot to change the bug number when I ended up filing a new bug for it. It should actually be bug 1533130. But I don't think it's worth backing out and relanding as the other bug does depend on this one. I'll just re-open this and dupe the other one.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 1533130
Status: REOPENED → RESOLVED
Closed: 5 months ago4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.