Closed Bug 1531460 Opened 5 years ago Closed 1 year ago

Implement RTCRtpSender.getCapabilities

Categories

(Core :: WebRTC: Signaling, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
113 Branch
Tracking Status
firefox113 --- fixed

People

(Reporter: bwc, Assigned: dbaker)

References

(Blocks 2 open bugs)

Details

(Keywords: dev-doc-complete)

Attachments

(5 files, 1 obsolete file)

No description provided.
See Also: → 1531461
Rank: 19
Priority: -- → P2
Blocks: 1533321
Severity: normal → S3
Assignee: nobody → dbaker

Depends on D173550

Depends on D173550

Pushed by dbaker@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/99b6e83a6291
Enable wpt getCapabilities tests.r=bwc
https://hg.mozilla.org/integration/autoland/rev/6cd802a21625
Implement getCapabilities.r=bwc,webrtc-reviewers,emilio
https://hg.mozilla.org/integration/autoland/rev/c8ec97292d07
Removing unused pref.r=bwc
https://hg.mozilla.org/integration/autoland/rev/efd17f1d735a
Enabled additional wpt getCapabilities tests.r=bwc

Backed out for causing wpt failures on decodingInfo.webrtc.html

Backout link

Push with failures

Failure log

Flags: needinfo?(dbaker)
Attachment #9325755 - Attachment is obsolete: true
Attachment #9325552 - Attachment description: Bug 1531460 - Enabled additional wpt getCapabilities tests.r?bwc → Bug 1531460 - Adding failure expectations to media wpt using getCapabilities.r?bwc
Attachment #9325552 - Attachment description: Bug 1531460 - Adding failure expectations to media wpt using getCapabilities.r?bwc → Bug 1531460 - Enabled additional wpt getCapabilities tests.r=bwc
Pushed by dbaker@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/220b6544f43d
Enable wpt getCapabilities tests.r=bwc
https://hg.mozilla.org/integration/autoland/rev/5d6a74012d4f
Implement getCapabilities.r=bwc,webrtc-reviewers,emilio
https://hg.mozilla.org/integration/autoland/rev/e1c237934c14
Removing unused pref.r=bwc
https://hg.mozilla.org/integration/autoland/rev/c0b7e1be2dbb
Enabled additional wpt getCapabilities tests.r=bwc
https://hg.mozilla.org/integration/autoland/rev/e8f3ccfc88e6
Adding failure expectations to media wpt using getCapabilities.r=bwc
Flags: needinfo?(dbaker)

Hey Dan, we added an Fx113 relnote for bug 1510802, but I'm wondering if we wanted to expand it to call out all the various new WebRTC functionality we're shipping in this release? It seems like a lot and worthy of calling out.

Flags: needinfo?(dbaker)
Flags: needinfo?(dbaker)

FYI MDN docs work for this can be tracked in https://github.com/mdn/content/issues/26146#issuecomment-1517277743

Duplicate of this bug: 1531461
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: