Closed Bug 1531593 Opened 1 year ago Closed 4 months ago

WebExtensions API for managing identities

Categories

(Thunderbird :: Add-Ons: Extensions API, enhancement, P2)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 76.0

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(1 file)

No description provided.
Priority: -- → P2
Blocks: 1617448
Blocks: 1624836
Assignee: nobody → geoff
Status: NEW → ASSIGNED

This is an API for reading the most useful information from identities. Like the rest of the accounts API it's read-only (except you can set the default identity) because changing any of this information should be done with the built-in user interface.

Attachment #9136237 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9136237 [details] [diff] [review]
1531593-identities-api-1.diff

Review of attachment 9136237 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #9136237 - Flags: review?(mkmelin+mozilla) → review+
Duplicate of this bug: 1624836

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/dd193b824445
WebExtensions API for reading identities. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 76.0
You need to log in before you can comment on or make changes to this bug.