Closed Bug 1531968 Opened 2 years ago Closed 1 year ago

Allow to search bugs by Firefox merge dates

Categories

(bugzilla.mozilla.org :: Search, enhancement)

Production
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: emceeaich, Assigned: kohei.yoshino)

References

Details

Attachments

(2 files)

There are several queries we ask triage owners to monitor.

  • All open bugs of type defect in your component without a pending needinfo flag or a stalled keyword since start of current release cycle which do not have a priorty set
  • All open bugs of type defect with pending needinfo flags in your component which have not been modified in two weeks
  • All open P1 bugs since start of current release cycle
  • All open P2 bugs since start of current release cycle

It would be useful to have some syntactic sugar for these searches:

  • Merge date of current release
  • Merge date of current beta
  • Merge date of current nightly

We could use the feed at https://product-details.mozilla.org/1.0/firefox_history_major_releases.json to get these dates.

See Also: → 1475740
See Also: → 1538115
Duplicate of this bug: 1475740
Assignee: nobody → kohei.yoshino

I think we can do this after Bug 1538115.

Depends on: 1538115
Type: enhancement → task
Status: NEW → ASSIGNED
Summary: [meta] Search enhancements for triage → Allows to search bugs by Firefox merge dates
Summary: Allows to search bugs by Firefox merge dates → Allow to search bugs by Firefox merge dates

I’m adding LAST_MERGE_DATE to firefox_versions.json that already has NEXT_MERGE_DATE.

(In reply to Emma Humphries, Bugmaster ☕️🎸🧞‍♀️✨ (she/her) [:emceeaich] (UTC-8) needinfo? me from comment #0)

It would be useful to have some syntactic sugar for these searches:

  • Merge date of current release
  • Merge date of current beta
  • Merge date of current nightly

Do you need all these dates, btw?

We could use the feed at https://product-details.mozilla.org/1.0/firefox_history_major_releases.json to get these dates.

These are release dates, so merge dates have to be maintained separately.

Flags: needinfo?(ehumphries)

My pull request for ship-it has been merged. Once it’s deployed, I’ll send a PR to BMO.

Those are useful for identifying when bugs were filed, but if I could have only one the Merge Date of the current release would be the most important.

Flags: needinfo?(ehumphries)

Sounds good.

Type: task → enhancement
Attached file GitHub Pull Request —

LAST_MERGE_DATE has been added to firefox_versions.json so here’s a PR for BMO.

Depends on: 1477931

(wrong bug ID)

Depends on: 1559988
No longer depends on: 1477931

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Blocks: 1568695
You need to log in before you can comment on or make changes to this bug.