Closed Bug 1533221 Opened 6 months ago Closed 5 months ago

Intermittent testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_additional_capabilities | AssertionError: u'/storage/emulated/0/tests/profile' != '/sdcard/tests/profile'

Categories

(Testing :: Marionette, defect, P1)

Version 3
defect

Tracking

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 fixed, firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- fixed
firefox68 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: gbrown)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file, 1 obsolete file)

#[markdown(off)]
Filed by: dluca [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=232326854&repo=autoland

https://queue.taskcluster.net/v1/task/HNOA3IR-RVOf4CInbuSZ_Q/runs/0/artifacts/public/logs/live_backing.log

TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_additional_capabilities
[task 2019-03-07T01:39:03.649Z] 01:39:03 WARNING - TEST-UNEXPECTED-FAIL | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_additional_capabilities | AssertionError: u'/storage/emulated/0/tests/profile' != '/sdcard/tests/profile'
[task 2019-03-07T01:39:03.650Z] 01:39:03 INFO - Traceback (most recent call last):
[task 2019-03-07T01:39:03.650Z] 01:39:03 INFO - File "/builds/worker/workspace/build/venv/lib/python2.7/site-packages/marionette_harness/marionette_test/testcases.py", line 159, in run
[task 2019-03-07T01:39:03.651Z] 01:39:03 INFO - testMethod()
[task 2019-03-07T01:39:03.651Z] 01:39:03 INFO - File "/builds/worker/workspace/build/tests/marionette/tests/testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py", line 102, in test_additional_capabilities
[task 2019-03-07T01:39:03.651Z] 01:39:03 INFO - self.assertEqual(self.caps["moz:profile"].lower(), current_profile.lower())
[task 2019-03-07T01:39:03.652Z] 01:39:03 INFO - TEST-INFO took 335ms
[task 2019-03-07T01:39:03.862Z] 01:39:03 INFO - TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_disable_webdriver_click
[task 2019-03-07T01:39:04.110Z] 01:39:04 INFO - TEST-PASS | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_disable_webdriver_click | took 250ms
[task 2019-03-07T01:39:04.316Z] 01:39:04 INFO - TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_mandated_capabilities
[task 2019-03-07T01:39:04.453Z] 01:39:04 INFO - TEST-PASS | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_mandated_capabilities | took 137ms
[task 2019-03-07T01:39:04.660Z] 01:39:04 INFO - TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_supported_features
[task 2019-03-07T01:39:04.796Z] 01:39:04 INFO - TEST-PASS | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_supported_features | took 135ms
[task 2019-03-07T01:39:05.001Z] 01:39:05 INFO - TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_use_non_spec_compliant_pointer_origin
[task 2019-03-07T01:39:05.249Z] 01:39:05 INFO - TEST-PASS | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_use_non_spec_compliant_pointer_origin | took 248ms
[task 2019-03-07T01:39:05.455Z] 01:39:05 INFO - TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_we_get_valid_uuid4_when_creating_a_session
[task 2019-03-07T01:39:05.584Z] 01:39:05 INFO - TEST-PASS | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilities.test_we_get_valid_uuid4_when_creating_a_session | took 129ms
[task 2019-03-07T01:39:05.792Z] 01:39:05 INFO - TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilityMatching.test_accept_insecure_certs
[task 2019-03-07T01:39:05.910Z] 01:39:05 INFO - type <type 'str'>
[task 2019-03-07T01:39:06.017Z] 01:39:06 INFO - type <type 'int'>
[task 2019-03-07T01:39:06.125Z] 01:39:06 INFO - type <type 'dict'>
[task 2019-03-07T01:39:06.234Z] 01:39:06 INFO - type <type 'list'>
[task 2019-03-07T01:39:06.476Z] 01:39:06 INFO - TEST-PASS | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilityMatching.test_accept_insecure_certs | took 685ms
[task 2019-03-07T01:39:06.681Z] 01:39:06 INFO - TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_capabilities.py TestCapabilityMatching.test_page_load_strategy

Looks like bug 1526084 didn't fix it completely. Geoff, can you please have a look?

Blocks: 1500509
Depends on: 1526084
Flags: needinfo?(gbrown)
Assignee: nobody → gbrown
Flags: needinfo?(gbrown)

This is quite speculative: What if one of the profile paths being compared here changes, such
that the condition is not satisfied in get_fennec_profile and links are not followed, and then the
unmodified profile path fails the assertion later? I do not see how that can happen, but maybe?
Also, removing the condition reduces the possible code paths, which might help us focus attention
if the intermittent persists.

Duplicate of this bug: 1536370
Status: NEW → ASSIGNED
Priority: P5 → P1
Attachment #9052484 - Attachment is obsolete: true
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ffe777450100
In Mn test_capabilities.py, compare only the basename of profile paths; r=whimboo
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.