Build geckodriver for aarch64 on Windows

REOPENED
Unassigned

Status

defect
P3
normal
REOPENED
4 months ago
4 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

Version 3
ARM64
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

#[markdown(off)]
Filed by: egao [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=233233998&repo=try

https://queue.taskcluster.net/v1/task/dyvVY6vJQJm6l8ChoONYBA/runs/0/artifacts/public/logs/live_backing.log

Test: wdspec-1, wdspec-2

Context:
22:29:01 INFO - Calling ['c:\\mozilla-build\\python\\python.exe', '-u', 'C:\\tasks\\task_1552102824\\mozharness\\external_tools\\tooltool.py', '--url', 'https://tooltool.mozilla-releng.net/', 'fetch', '-m', 'C:\\tasks\\task_1552102824\\build\\tests\\config/tooltool-manifests/win32/releng.manifest', '-o', '-c', 'C:\\tooltool-cache'] with output_timeout 600
22:29:01 INFO - INFO - File win32-minidump_stackwalk.exe retrieved from local cache C:\tooltool-cache
22:29:01 INFO - Return code: 0
22:29:01 INFO - Chmoding C:\tasks\task_1552102824\build\win32-minidump_stackwalk.exe to 0755
22:29:01 FATAL - Unable to find geckodriver binary in common test package: C:\tasks\task_1552102824\build\tests\bin\geckodriver.exe
22:29:01 FATAL - Running post_fatal callback...
22:29:01 FATAL - Exiting -1
22:29:01 INFO - Running post-action listener: _package_coverage_data
22:29:01 INFO - Running post-action listener: _resource_record_post_action
22:29:01 INFO - Running post-action listener: process_java_coverage_data
22:29:01 INFO - Running post-action listener: stop_device

:ato - I'm greening up the tests for windows10-aarch64, but there isn't an abundance of geckodriver.exe issues, though in 1442340 I saw some comments made by you. Are you the correct person to contact regarding this issue, or is there another person better suited to help?

Flags: needinfo?(ato)

This is explained by the fact that we don’t build geckodriver on aarch64.

Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(ato)
Resolution: --- → WONTFIX

Why is that a wontfix? As it looks like we want to run all the tests on that platform and as such we would need a geckodriver build. For the time being we might have to disable the webdriver tests for aarch64.

Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

(I mid-aired with whimboo...)

(In reply to Andreas Tolfsen ⦗:ato⦘ from comment #2)

This is explained by the fact that we don’t build geckodriver on aarch64.

Then the action item for this bug should be to disable the tests, preferably with a comment explaining why we don't currently build geckodriver, so that we know how to re-evaluate whether we can enable it in the future.

Keywords: regression
OS: Unspecified → Windows
Hardware: Unspecified → ARM64
Summary: windows/aarch64 - Unable to find geckodriver binary in common test package: C:\tasks\task_1552102824\build\tests\bin\geckodriver.exe → Build geckodriver for aarch64 on Windows

Thanks for digging that up. The underlying tracking issue seems
to be https://github.com/retep998/winapi-rs/issues/727.

You need to log in before you can comment on or make changes to this bug.