Closed Bug 1534738 Opened 8 months ago Closed 6 months ago

[RTL] Quantumbar autocomplete urls are shown from the end of the URL instead of its beginning

Categories

(Firefox :: Address Bar, defect, P2)

defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 68
Iteration:
68.3 - Apr 15 - 28
Tracking Status
firefox68 --- verified

People

(Reporter: itiel_yn8, Assigned: mak)

References

(Regressed 1 open bug)

Details

(Keywords: rtl)

Attachments

(3 files)

Attached image Screenshot

See attached.
This works okay in non-quantumbar.

Thanks, this is important for RTL.

Priority: -- → P2
Blocks: 1534939

Duplicate of bug 1534735?

Flags: needinfo?(standard8)
Flags: needinfo?(itiel_yn8)

(In reply to Dão Gottwald [::dao] from comment #2)

Duplicate of bug 1534735?

I don't think so. At least, this is still not fixed after bug 1534735.
See attached.

Flags: needinfo?(standard8)
Flags: needinfo?(itiel_yn8)
Attached image Screenshot 2

Bug 1534735 probably helps towards this, since we can now apply the gradient to the other end of the urls/secondary spans easily.

However, we'll need to somehow limit the widths of the secondary spans and make it overflow at the other end.

When I had a quick glance at it last week, I couldn't see an 5-minute way to do that so I went with just fixing the one bug to begin with.

Points: --- → 3
Assignee: nobody → mak77
Iteration: --- → 68.3 - Apr 15 - 28

Moves the mask to the url and title elements, uses a flex layout to ensure
elements properly overflow, and fixes alignments and paddings because the new
layout would be more compact. rows are slightly taller than before, but they were
smaller than the legacy bar, so in the end we should be good.

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/841e248130ae
Title and url in RTL mode are not properly overflowing in Quantum Bar. r=dao
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

This looks very nice on latest Nightly, thank you! I couldn't find any edge cases (yet) where this doesn't work as expected.
I'm guessing the fading effect is here to stay, instead of the ellipsis?

Status: RESOLVED → VERIFIED
Blocks: 1552106
Regressions: 1570195
You need to log in before you can comment on or make changes to this bug.