Closed Bug 1535200 Opened 8 months ago Closed 8 months ago

Support column-span for columns on <fieldset>

Categories

(Core :: Layout: Columns, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: TYLin, Assigned: TYLin)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1489295 +++

Bug 1421105 implements "column-span" for block and inline frames only. <fieldset> are still using InitAndWrapInColumnSetFrameIfNeeded() to construct column hierarchy, which is unaware of "column-span".

Per spec, "Note: Column boxes do not become the containing block for
elements with position: fixed or position: absolute. The containing
block is the multicol container, it being the principal box."

https://drafts.csswg.org/css-multicol-1/#the-multi-column-model

contentFrame and contentFrameTop are different only if fieldset has
multicol layout. In that case, contentFrameTop is nsColumnSetFrame (or
ColumnSetWrapperFrame after applying Part 2 with
layout.css.column-span.enabled=true).

Duplicate of this bug: 1535156
Pushed by aethanyc@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1070ea9495a0
Part 1 - In fieldset, make absolute positioned frames relative to multicol container, not the column content frames. r=mats
https://hg.mozilla.org/integration/autoland/rev/803ea92e7423
Part 2 - Implement column-span:all for fieldset elements. r=dbaron
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/16002 for changes under testing/web-platform/tests
Upstream PR was closed without merging
You need to log in before you can comment on or make changes to this bug.