Open Bug 1535451 Opened 3 years ago Updated 26 days ago

Perma Tier 2 devtools/client/webconsole/test/browser/browser_webconsole_trackingprotection_errors.js | Uncaught exception - waitFor - timed out after 500 tries.

Categories

(DevTools :: Console, defect, P5)

defect

Tracking

(Fission Milestone:Future)

REOPENED
Fission Milestone Future

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: intermittent-failure, leave-open, regression, Whiteboard: [stockwell disabled] dt-fission-future)

Attachments

(2 files)

#[markdown(off)]
Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=233959582&repo=autoland

https://queue.taskcluster.net/v1/task/NRyXMpjJTSaSWPEk39rmow/runs/0/artifacts/public/logs/live_backing.log

0:17:18 INFO - TEST-START | devtools/client/webconsole/test/mochitest/browser_webconsole_trackingprotection_errors.js
20:17:19 INFO - GECKO(4056) | _create_dc_and_bitmap: Not enough storage is available to process this command.
20:17:28 INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_webconsole_trackingprotection_errors.js | Clicking the provided link opens in expected tab -
20:17:28 INFO - Leaving test bound testForeignCookieBlockedMessage
20:17:28 INFO - Entering test bound testLimitForeignCookieBlockedMessage
20:17:28 INFO - Test unvisited eTLD foreign cookies blocked message
20:17:28 INFO - Buffered messages logged at 20:17:23
20:17:28 INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/webconsole/test/mochitest/test-trackingprotection-securityerrors.html
20:17:28 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “http://tracking.example.org/” was blocked because we are blocking all third-party storage access requests and content blocking is enabled." {file: "http://example.com/browser/devtools/client/webconsole/test/mochitest/test-trackingprotection-securityerrors.html" line: 0}]
20:17:28 INFO - Tab added and finished loading
20:17:28 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “http://tracking.example.org/” was blocked because we are blocking all third-party storage access requests and content blocking is enabled." {file: "http://example.com/browser/devtools/client/webconsole/test/mochitest/test-trackingprotection-securityerrors.html" line: 0}]
20:17:28 INFO - Console message: [JavaScript Error: "uncaught exception: out of memory"]
20:17:28 INFO - Console message: [JavaScript Error: "uncaught exception: out of memory"]
20:17:28 INFO - Console message: [JavaScript Error: "uncaught exception: out of memory"]
20:17:28 INFO - Console message: [JavaScript Error: "uncaught exception: out of memory"]
20:17:28 INFO - Console message: [JavaScript Error: "uncaught exception: out of memory"]
20:17:28 INFO - Console message: [JavaScript Error: "uncaught exception: out of memory"]
20:17:28 INFO - Console message: [JavaScript Error: "uncaught exception: out of memory"]
20:17:28 INFO - Console message: [JavaScript Error: "uncaught exception: out of memory"]
20:17:28 INFO - Buffered messages finished
20:17:28 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/mochitest/browser_webconsole_trackingprotection_errors.js | Uncaught exception - waitFor - timed out after 500 tries.
20:17:28 INFO - Not taking screenshot here: see the one that was previously logged
20:17:28 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/mochitest/browser_webconsole_trackingprotection_errors.js | A promise chain failed to handle a rejection: out of memory - stack: (No stack available.)
20:17:28 INFO - Rejection date: Thu Mar 14 2019 20:17:23 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
20:17:28 INFO - Stack trace:
20:17:28 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
20:17:28 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1130
20:17:28 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1134
20:17:28 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:995
20:17:28 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
20:17:28 INFO - Leaving test bound testLimitForeignCookieBlockedMessage
20:17:28 INFO - Entering test bound testAllCookieBlockedMessage
20:17:28 INFO - Test all cookies blocked message
20:17:28 INFO - GECKO(4056) | [GFX1-]: Failed buffer for 0, 0, 1264, 1016
20:17:28 INFO - GECKO(4056) | _create_dc_and_bitmap: Not enough storage is available to process this command.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE

New perma failure: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=263841004&repo=mozilla-central&lineNumber=5574

[task 2019-08-28T11:40:51.258Z] 11:40:51 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “http://tracking.example.org/browser/devtools/client/webconsole/test/browser/cookieSetter.html” was blocked because we are blocking all third-party storage access requests and content blocking is enabled." {file: "http://tracking.example.org/browser/devtools/client/webconsole/test/browser/cookieSetter.html" line: 0}]
[task 2019-08-28T11:40:51.258Z] 11:40:51 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://tracking.example.org/browser/devtools/client/webconsole/test/browser/cookieSetter.html" line: 0}]
[task 2019-08-28T11:40:51.258Z] 11:40:51 INFO - Console message: [JavaScript Error: "SecurityError: Permission denied to access property "document" on cross-origin object" {file: "resource:///actors/PageStyleChild.jsm" line: 35}]
[task 2019-08-28T11:40:51.258Z] 11:40:51 INFO - Buffered messages logged at 11:40:40
[task 2019-08-28T11:40:51.259Z] 11:40:51 INFO - Clicking on the Learn More link
[task 2019-08-28T11:40:51.259Z] 11:40:51 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_trackingprotection_errors.js | Clicking the provided link opens https://developer.mozilla.org/docs/Mozilla/Firefox/Privacy/Storage_access_policy/Errors/CookieBlockedForeign?utm_source=devtools&utm_medium=firefox-cookie-errors&utm_campaign=default -
[task 2019-08-28T11:40:51.259Z] 11:40:51 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_trackingprotection_errors.js | Clicking the provided link opens in expected tab -
[task 2019-08-28T11:40:51.259Z] 11:40:51 INFO - Leaving test bound testForeignCookieBlockedMessage
[task 2019-08-28T11:40:51.259Z] 11:40:51 INFO - Entering test bound testLimitForeignCookieBlockedMessage
[task 2019-08-28T11:40:51.259Z] 11:40:51 INFO - Test unvisited eTLD foreign cookies blocked message
[task 2019-08-28T11:40:51.259Z] 11:40:51 INFO - Buffered messages logged at 11:40:44
[task 2019-08-28T11:40:51.259Z] 11:40:51 INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/webconsole/test/browser/test-trackingprotection-securityerrors.html
[task 2019-08-28T11:40:51.259Z] 11:40:51 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://tracking.example.org/browser/devtools/client/webconsole/test/browser/cookieSetter.html" line: 0}]
[task 2019-08-28T11:40:51.259Z] 11:40:51 INFO - Tab added and finished loading
[task 2019-08-28T11:40:51.260Z] 11:40:51 INFO - Console message: [JavaScript Error: "SecurityError: Permission denied to access property "document" on cross-origin object" {file: "resource:///actors/PageStyleChild.jsm" line: 35}]
[task 2019-08-28T11:40:51.260Z] 11:40:51 INFO - Buffered messages finished
[task 2019-08-28T11:40:51.260Z] 11:40:51 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/browser/browser_webconsole_trackingprotection_errors.js | Uncaught exception - waitFor - timed out after 500 tries.
[task 2019-08-28T11:40:51.260Z] 11:40:51 INFO - Leaving test bound testLimitForeignCookieBlockedMessage
[task 2019-08-28T11:40:51.260Z] 11:40:51 INFO - Entering test bound testAllCookieBlockedMessage
[task 2019-08-28T11:40:51.260Z] 11:40:51 INFO - Test all cookies blocked message
[task 2019-08-28T11:40:51.525Z] 11:40:51 INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/webconsole/test/browser/test-trackingprotection-securityerrors.html
[task 2019-08-28T11:40:51.714Z] 11:40:51 INFO - GECKO(2376) | Assertion failure
[task 2019-08-28T11:40:51.715Z] 11:40:51 INFO - GECKO(2376) | assert@resource:///modules/AsyncTabSwitcher.jsm:490:36
[task 2019-08-28T11:40:51.715Z] 11:40:51 INFO - GECKO(2376) | onLayersCleared@resource:///modules/AsyncTabSwitcher.jsm:827:12
[task 2019-08-28T11:40:51.715Z] 11:40:51 INFO - GECKO(2376) | handleEvent@resource:///modules/AsyncTabSwitcher.jsm:1131:16
[task 2019-08-28T11:40:51.716Z] 11:40:51 INFO - GECKO(2376) | EventListener.handleEvent*AsyncTabSwitcher@resource:///modules/AsyncTabSwitcher.jsm:155:17
[task 2019-08-28T11:40:51.716Z] 11:40:51 INFO - GECKO(2376) | _getSwitcher@chrome://browser/content/tabbrowser.js:4705:26
[task 2019-08-28T11:40:51.719Z] 11:40:51 INFO - GECKO(2376) | updateCurrentBrowser@chrome://browser/content/tabbrowser.js:1019:16
[task 2019-08-28T11:40:51.720Z] 11:40:51 INFO - GECKO(2376) | _setupEventListeners/<@chrome://browser/content/tabbrowser.js:5107:16
[task 2019-08-28T11:40:51.720Z] 11:40:51 INFO - GECKO(2376) | set selectedIndex@chrome://global/content/elements/tabbox.js:208:14
[task 2019-08-28T11:40:51.720Z] 11:40:51 INFO - GECKO(2376) | set selectedPanel@chrome://global/content/elements/tabbox.js:227:7
[task 2019-08-28T11:40:51.720Z] 11:40:51 INFO - GECKO(2376) | set selectedIndex@chrome://global/content/elements/tabbox.js:571:11
[task 2019-08-28T11:40:51.720Z] 11:40:51 INFO - GECKO(2376) | set selectedItem@chrome://global/content/elements/tabbox.js:591:35
[task 2019-08-28T11:40:51.720Z] 11:40:51 INFO - GECKO(2376) | set selectedTab@chrome://global/content/elements/tabbox.js:98:11
[task 2019-08-28T11:40:51.720Z] 11:40:51 INFO - GECKO(2376) | set selectedTab@chrome://browser/content/tabbrowser.js:312:7

Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Summary: Intermittent devtools/client/webconsole/test/mochitest/browser_webconsole_trackingprotection_errors.js | Uncaught exception - waitFor - timed out after 500 tries. → Perma Tier 2 devtools/client/webconsole/test/mochitest/browser_webconsole_trackingprotection_errors.js | Uncaught exception - waitFor - timed out after 500 tries.

This looks to be a fallout from Bug 1576841 https://hg.mozilla.org/mozilla-central/rev/da73ca6c2e2fc76729e589e1afe988754aab287d
Nicholas, can you please take a look?

Flags: needinfo?(nchevobbe)
Assignee: nobody → nchevobbe
Status: REOPENED → ASSIGNED
Flags: needinfo?(nchevobbe)
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/59e90b5a43fa
Fix browser_webconsole_trackingprotection_errors.js intermittent. r=Honza.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

Nicolas should we just disable the test?

Let's do that for now, I'm not sure what's happening.

Flags: needinfo?(nchevobbe)
Whiteboard: [stockwell disabled]

Pushed by btara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/278c07df138f
Skip browser_webconsole_trackingprotection_errors.js on fission. r=nchevobbe

Keywords: checkin-needed
Fission Milestone: --- → M4.1

This browser_webconsole_trackingprotection_errors.js test is still disabled for Fission.

DevTools bugs don't need to block Fission mochitests milestone (M4.1) because there is a lot of Fission DevTools work remaining. Tracking for Fission Nightly (M6).

Fission Milestone: M4.1 → M6

This web console test is still skipped for Fission:

https://searchfox.org/mozilla-central/source/devtools/client/webconsole/test/browser/_webconsole.ini#371-372

[browser_webconsole_trackingprotection_errors.js]
skip-if = fission #Bug 1535451

Adding dt-fission whiteboard tag to DevTools bugs that mention Fission or block Fission meta bugs but don't already have a dt-fission whiteboard tag.

Assignee: nchevobbe → nobody
Fission Milestone: M6 → M6c
Whiteboard: [stockwell disabled] → [stockwell disabled] dt-fission

Moving dt-fission bugs to Fission MVP.

Fission Milestone: M6c → MVP

"dt-fission" bugs don't block Fission MVP.

Fission Milestone: MVP → Future
Whiteboard: [stockwell disabled] dt-fission → [stockwell disabled] dt-fission-future
Summary: Perma Tier 2 devtools/client/webconsole/test/mochitest/browser_webconsole_trackingprotection_errors.js | Uncaught exception - waitFor - timed out after 500 tries. → Perma Tier 2 devtools/client/webconsole/test/browser/browser_webconsole_trackingprotection_errors.js | Uncaught exception - waitFor - timed out after 500 tries.

This seem to fails on fission because of this code:
https://searchfox.org/mozilla-central/rev/4fe6dea30b40a6c34616d57ac0b9444e677c5be2/toolkit/components/antitracking/ContentBlockingNotifier.cpp#207,223
We emit console service notifications with the innerWindowID of the top BrowsingContext/WindowGlobal.
This ultimately ends up confusing this DevTools code:
https://searchfox.org/mozilla-central/rev/364aa1d41eb9b5ea583fa6cedc56fb5343e3514f/devtools/server/actors/resources/error-messages.js#88-90
message's innerWindowId ends up being the top level WindowGlobal's one instead of the iframe one.
The Error Message resource listener that receives the message is the iframe one, and it is only dispatched in the iframe's process.
So the top document's one isn't receiving the message, and even if it was, it would ignore it as we only accept same-process iframe messages.

Note that browser_webconsole_warning_group_storage_isolation.js is being disabled on fission for a similar reason. (bug 1653057)

You need to log in before you can comment on or make changes to this bug.