Address bar don't have focus when navigator started by systray

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
minor
RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: Cédric BARBOIRON, Assigned: Samir Gehani)

Tracking

(Blocks: 2 bugs)

Trunk
x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a+) Gecko/20020622
BuildID:    2002062204

On win32, when you open navigator from systray (quickstart), the address-bar
don't have the focus

Reproducible: Always
Steps to Reproduce:
1. open navigator by double-clicking on mozilla systray icon
2. address-bar doesnt have focus, you need to click on it to type an url

Expected Results:  Address-bar should have focus when mozilla is started

Comment 1

15 years ago
I confirm that this problem exists with Phoenix 0.5 running on Windows 2000 sp3.

Furthermore:

Pressing Alt+D or Control+L results in an error beep, rather than giving focus
to the address bar.

The other keyboard shortcuts (Alt+F for File menu, Control+W to close the
window, etc.) are also broken when in this strange mode.

The Windows system keyboard shortcuts (Control+F4, Alt+Space, etc.) continue to
work properly in this mode.

This only seems to happen when the home page is set to "" or "about:blank".

This will happen not only when Phoenix is started from the systray (phoenix.exe
-turbo), but also any time I start a new instance of the phoenix executable (run
phoenix.exe from the command line / Start menu / Windows hotkeys) while a
phoenix process is already running.

Comment 2

15 years ago
Same when you start mozilla.exe with quickstart activated.

OS: Win 2k SP3

Comment 3

15 years ago
Actually it doesn't matter if you're using Quickstart or not since
starting a second browser using the shortcut to mozilla.exe does not
give the focus to the second window.

Updated

15 years ago
Blocks: 83552

Comment 4

15 years ago
For blank home page, bug 192915 is the no-quicklaunch version of this bug.

Comment 5

15 years ago
*** Bug 199666 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 55416

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: Core → Mozilla Application Suite

Comment 6

11 years ago
WFM 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060918 SeaMonkey/1.5a

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.