Pin FIrefox shortcut on taskbar for Windows 10 users

RESOLVED FIXED in Firefox 68

Status

()

enhancement
P1
normal
RESOLVED FIXED
4 months ago
24 days ago

People

(Reporter: RT, Assigned: mhowell)

Tracking

68 Branch
Firefox 68
Desktop
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 68+, firefox68+ fixed)

Details

Attachments

(1 attachment)

After a succesful A/B test that demonstrated retention and engagement gains (see results on bug 1506648), we'd like to ship the capability to place a taskbar Firefox shortcut for Windows 10 new installs on release at install time, across all locales, for 32 and 64 bit installations.
This should ideally happen with Firefox 68.

To be clarified: do we need a command line parameter to disable this for enterprise scenarios?

I think we can do with within the 68 cycle, so prioritizing to indicate that.

(In reply to Romain Testard [:RT] from comment #0)

To be clarified: do we need a command line parameter to disable this for enterprise scenarios?

We already have a TaskbarShortcut parameter that does this (also in the MSI).

Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Priority: -- → P1
Posted patch PatchSplinter Review

For the record, this is the patch I'm going to land. It's identical to the patch in bug 1493597 except with the A/B testing switch removed, so I'm carrying over the r+ from there.

Attachment #9059355 - Flags: review+

Since this is a late addition to 68 features, Julien requested an exception from engg (JoeH), prod (NickN) and got an approval. We are good to land this in Nightly68 today.

If there are unexpected regressions due to this change, the risk mitigation would be to back out this patch promptly and well before 68 merges to Beta on May 13th.

Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8c09cf1ee1e5
Support pinning to the taskbar on Windows 10. r=agashlin
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Blocks: 1545995

This is in the 68.0beta release notes as "Added a Firefox shortcut in the Windows 10 taskbar for new installations"

You need to log in before you can comment on or make changes to this bug.