Unable to enter a lower case “p” in the To, CC, BCC, Subject, or Address Picker fields on IBM Web Mail on FireFox 66

RESOLVED FIXED

Status

()

defect
P1
normal
RESOLVED FIXED
2 months ago
a month ago

People

(Reporter: sisingh, Assigned: denschub)

Tracking

(Regression, {regression})

66 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66+ fixed, firefox67 fixed, firefox68 fixed)

Details

Reporter

Description

2 months ago

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36

Steps to reproduce:

  1. Logged in to https://mail.notes.na.collabserv.com/livemail/iNotes/
  2. Click on new email
  3. In To, or CC or BCC or Address picker field try to type - any sentence with Capital P or small p;
  4. cannot type the letter “p” in the To, CC,BCC, field

Actual results:

cannot type the letter “p” in the To, CC,BCC, field

Expected results:

To, CC,BCC, field should allow typing of small p

Older versions of FireFox as well as any other browsers are working fine

Comment 1

2 months ago

SuMo thread: https://support.mozilla.org/questions/1253981

Likely related to the keyCode/charCode change: bug 1502795, bug 1536453, and bug 1538126

Component: Untriaged → DOM: Events
Product: Firefox → Core
Assignee

Comment 3

2 months ago

According to the reporter on SuMo, this is fixed by adding the mail host (in this case ``) to dom.keyboardevent.keypress.hack.use_legacy_keycode_and_charcode, so this is probably related to bug 1536453. We're having discussions on what to do here. ni? myself to come back when we know how to react.

Blocks: 1502795
Flags: needinfo?(dschubert)
Keywords: regression
See Also: → 1536453
Depends on: 1538966

Comment 5

2 months ago

Hello,

We have this application hosted on a number of subdomains
mail.notes.na.collabserv.com
mail.notes.ap.collabserv.com
mail.notes.ce.collabserv.com
And as per https://bugzilla.mozilla.org/show_bug.cgi?id=1538970
can we include a wild card
*.collabserv.com And *.scniris.com (our preview domain) that would catch all subdomains ? (eg
webchat.na.collabserv.com & mail.notes.scniris.com ) and the rest mentioned here
https://www-10.lotus.com/ldd/bhwiki.nsf/dx/Cheat_Sheetcol_Firewall_Settings_for_IBM_SmartCloud_Engage_Advanced

Assignee

Comment 6

2 months ago

can we include a wild card
*.collabserv.com And *.scniris.com (our preview domain) that would catch all subdomains ?

We sure can. The patch over in bug 1538970 adds those two domains, thanks for the suggestion. Please note that this is meant as a temporary solution only. Ideally, we'd get the application's code fixed so it no longer depends on legacy code, because we really want to get rid of it at some point. :) Is there anything you can do to help us here?

If you need any help with identifying the root cause, we're happy to jump in. Feel free to mail dschubert@mozilla.com if you have any questions!

Updated

2 months ago
Priority: -- → P1
Has STR: --- → yes

Comment 7

2 months ago

I think the release note is misleading. There are a lot of Notes Webmails on premise and they have still this bug.

Reporter

Comment 8

2 months ago

Hi Dennis,

Thanks a lot for taking the time to fix the issue outlined in https://bugzilla.mozilla.org/show_bug.cgi?id=1538317

As you mentioned in the bug that ideally applications bug must be fixed and I am working with Dev team here at IBM to get it fixed permanently.

Wanted to ask if you could help me get more info on what was the root cause and fix you applied, which I can pass on to dev team, which they can leverage to get to a permanent solution in their respective code.

Looking forward to your response on this!

Comment 9

2 months ago

(In reply to itd from comment #7)

I think the release note is misleading. There are a lot of Notes Webmails on premise and they have still this bug.

The preference that applies old behavior to specific hosts can be edited manually to list additional hosts. Do we need a support article on that? Roughly speaking, here are the steps:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste hack and pause while the list is filtered

What do you have listed for the value of the dom.keyboardevent.keypress.hack.use_legacy_keycode_and_charcode preference? Firefox 66.0.2 should update it to the following (all on one line), although I needed to restart Firefox an extra time to reflect it:

*.collabserv.com,*.gov.online.office365.us,*.officeapps-df.live.com,
*.officeapps.live.com,*.online.office.de,*.partner.officewebapps.cn,*.scniris.com

You can add a new host name to the beginning or end of the list: beginning followed by comma and no space, or end, following a comma with no space.

Comment 10

2 months ago

(In reply to sisingh from comment #8)

Wanted to ask if you could help me get more info on what was the root cause and fix you applied, which I can pass on to dev team, which they can leverage to get to a permanent solution in their respective code.

This is the change that is reverted by adding a host name to the dom.keyboardevent.keypress.hack.use_legacy_keycode_and_charcode preference:

This was fixed by 66.0.2. For the on-premise stuff, we have Bug 1540158 to explore solutions there.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
See Also: → 1540158
Assignee: nobody → dschubert
No longer blocks: 1502795
Regressed by: 1502795
You need to log in before you can comment on or make changes to this bug.