Closed Bug 1541129 Opened 5 months ago Closed 4 months ago

Firefox is rendering poorly on standard DPI external screen

Categories

(Core :: Graphics: Text, defect, P3)

Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1542738
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: flod, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image Example from Twitter

I'm not sure if it's Nightly, or the recent update to macOS 10.14.4 (18E226), but Firefox renders very poorly on an external monitor (27", 2560x1440).

I haven't seen the same issue with the macbook connected to a 4k external monitor.

The issue is particularly evident on light font on dark background, both for content and UI.

Awww, my eyes...

Component: Untriaged → Graphics: Text
Product: Firefox → Core
Priority: -- → P3

I don't believe this is a P3, and it's either a regression, or a compatibility problem with 10.14.4.
Right now, Firefox is pretty much unusable on this screen if you use websites with dark background. And there are a lot of them.

I'll try to check if I can reproduce on other machines in the office, to make sure it's not just my issue.

There have been a few macOS font rendering regressions related to subpixel antialiasing changes in macOS 10.14, such as bug 1531867 and bug 1532171 fixed in Firefox 66.

Bisecting with mozregression between Firefox 64 and the latest Nightly would be helpful.

duplication of Bug 1542738 ?

It looks like it. This one was filed before, but the other one already has a regression range.

I can reproduce this font rendering bug on my external display. I tested Lee's try build [1] and it appears to fix the bug for me. I'm going to close this bug as a dupe of bug 1542738 because it has a regression range and Lee is needinfo'd there.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=5213142e83c23d15b8f79d39f628851dd6bd94b0&selectedJob=239168088

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
See Also: → 1542738
Duplicate of bug: 1542738
You need to log in before you can comment on or make changes to this bug.