Improve layout of wide list item markers/counters (ordered, number, clipped, overflow, truncated, fit)

NEW
Unassigned

Status

()

Core
Layout: Block and Inline
P3
normal
19 years ago
2 years ago

People

(Reporter: Greg K., Unassigned)

Tracking

({css3, helpwanted, testcase})

Trunk
Future
css3, helpwanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
When given a list item with a marker value which, when rendered, will likely consume more space than the approximately one-half inch allocated it by Mozilla, nothing is done to provide space for the marker to display in its' entirety. At the example URI, the final list item is designated with the marker value 1998 to be displayed as a roman numeral. The rightmost portion of the marker is displayed, and the remainder flows off the left side of the page.

The programmer should not have to provide accompanying styles to provide proper basic display.

Updated

19 years ago
Assignee: don → troy
Component: Browser-General → Layout

Updated

19 years ago
Assignee: troy → kipp

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → LATER

Comment 1

19 years ago
Unless we were to implement a two pass list layout (very expensive and slow),
this will never look right. I'm latering this. There is no requirement in css or
html to handle these sort of edge cases. Using css2, however, you can fix things
so that they work by using the marker properties. This is still a latered issue
because we don't yet support css2 marker properties.

Comment 2

18 years ago
Resetting QA contact from leger.

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
Created attachment 25276 [details]
Simple test case for this bug.
(Reporter)

Comment 4

17 years ago
Alterting the summary to correctly mention list item markers rather than simply
list items.
Summary: Improper Layout of Long List Items → Improper Layout of Long List Item Markers or Counters
(Reporter)

Comment 5

17 years ago
Propose targeting as Future, unless there are any new ideas on how to resolve.
(Reporter)

Updated

17 years ago
Status: VERIFIED → REOPENED
Depends on: 14983
Resolution: LATER → ---
(Reporter)

Comment 6

17 years ago
This bug was marked LATER at a time when I believe that term was used in place
of FUTURE. I'm going to reopen as it seems more appropriate that it be marked as
the latter rather than the former. Also adding a dependency on the
display:marker CSS2 bug.
(Reporter)

Updated

17 years ago
Target Milestone: --- → Future
(Reporter)

Updated

17 years ago
Keywords: css2
(Reporter)

Updated

17 years ago
Keywords: helpwanted, testcase
Build reassigning Buster's bugs to Marc.
Assignee: buster → attinasi
Status: REOPENED → NEW
(Reporter)

Updated

17 years ago
Summary: Improper Layout of Long List Item Markers or Counters → Improper Layout of Wide List Item Markers or Counters
(Reporter)

Updated

17 years ago
Summary: Improper Layout of Wide List Item Markers or Counters → Display of Wide List Item Markers or Counters is Suboptimal
(Reporter)

Comment 8

16 years ago
*** Bug 46140 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

16 years ago
Okay, so how can this be fixed if display:marker (bug 14983) is WONTFIX?
*** Bug 162965 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

15 years ago
Summary: Display of Wide List Item Markers or Counters is Suboptimal → Improve layout of wide list item markers/counters

Comment 11

14 years ago
(In reply to comment #9)
> Okay, so how can this be fixed if display:marker (bug 14983) is WONTFIX?

This should probably be implanted using a pseudo-class proposed in css3-content,
::marker.
Keywords: qawanted
QA Contact: chrispetersen → ian

Comment 12

14 years ago
pseudo-element*

Updated

14 years ago
Keywords: css2, qawanted → css3
*** Bug 280024 has been marked as a duplicate of this bug. ***
Created attachment 172820 [details]
Testcase #2
David, an improvement would be to use relative units for the padding instead
of the default '-moz-padding-start: 40px' in html.css.

Try font-zooming "Testcase #2" to see what I mean.
I think '2.5em' works much better.
Assignee: attinasi → nobody
QA Contact: ian → layout
*** Bug 284117 has been marked as a duplicate of this bug. ***
*** Bug 303212 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 18

13 years ago
Re-addressing comment 2, in the nearly six years since this bug was filed
computing power has increased to the point where a two-pass layout is minimally
expensive and far from slow.
*** Bug 311552 has been marked as a duplicate of this bug. ***

Comment 20

11 years ago
Linking to the current active bugs on this subject: display: marker won't be
implemented (https://bugzilla.mozilla.org/show_bug.cgi?id=14983) -- instead
mozilla will eventually "Support CSS3's ::marker pseudo element"
(https://bugzilla.mozilla.org/show_bug.cgi?id=205202).

When 205202 is fixed you'll have proper positioning, etc of the LI marker.

Updated

10 years ago
Duplicate of this bug: 423347

Updated

10 years ago
Duplicate of this bug: 426312
Component: Layout → Layout: Block and Inline
QA Contact: layout → layout.block-and-inline

Updated

5 years ago
Duplicate of this bug: 804506

Updated

3 years ago
Duplicate of this bug: 1103903

Updated

3 years ago
Summary: Improve layout of wide list item markers/counters → Improve layout of wide list item markers/counters (ordered, number, clipped, overflow, truncated, fit)
You need to log in before you can comment on or make changes to this bug.