Open Bug 1543853 Opened 3 years ago Updated 2 years ago

Evaluate using stylebench for PGO training

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

People

(Reporter: erahm, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 obsolete file)

We would like to evaluate using the stylebench perf test for PGO training. This exercises an extensive rust code base used by the style system and will be useful once we have rust PGO enabled.

Work can start by building on top of the initial patches for bug 1437452 that enable rust PGO on Linux.

Type: defect → enhancement
Depends on: 1602801
Depends on: 1602806
Attached file Add StyleBench to PGO training (obsolete) —

Now that we have Rust PGO, training on this set can actually make a difference (and in fact may be needed in order to see a difference from Rust PGO at all).

Assignee: nobody → dmajor
Pushed by dmajor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ebbc8a9e9737
Add StyleBench to PGO training r=firefox-build-system-reviewers,rstewart
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Regressions: 1603482
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla73 → ---
Status: REOPENED → ASSIGNED

Backout improvement:
== Change summary for alert #24510 (as of Tue, 17 Dec 2019 18:59:34 GMT) ==

Improvements:

6% perf_reftest_singletons getElementById-1.html windows10-64-shippable-qr opt e10s stylo 54.95 -> 51.47
6% perf_reftest_singletons getElementById-1.html windows10-64-shippable opt e10s stylo 54.80 -> 51.34

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=24510

I attempted to revisit this using just one iteration of StyleBench (vs its default of 10): https://hg.mozilla.org/try/rev/7bfca42fd6f7cf34a264cdb8ef3a866fdd8eb977

Perf results showed a low-confidence 1.29% improvement on StyleBench, and mixed results on the reftest_singletons that had previously regressed. At this point I don't really have much enthusiasm to pursue this further. I'm not outright resolving the bug though because maybe things could change in the future.

Assignee: dmajor → nobody
Status: ASSIGNED → NEW
Attachment #9115210 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.