Some One-Click Search Engines are constantly readded after each Mozilla Firefox update after landing patches from bug #1496075

VERIFIED FIXED in Firefox 68

Status

()

defect
P1
major
VERIFIED FIXED
2 months ago
26 days ago

People

(Reporter: Virtual, Assigned: daleharvey)

Tracking

(Regression, {nightly-community, regression, reproducible})

68 Branch
Firefox 68
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68+ verified)

Details

Attachments

(2 attachments, 2 obsolete attachments)

STR:

  1. Go to Options ( about:preferences )
  2. Select "Search" tab ( about:preferences#search )
  3. Remove all One-Click Search Engines leaving only "Google"
  4. Wait for daily Mozilla Firefox Nightl update
    and after update:
  • Amazon.com
  • Twitter
  • Wikipedia (en)
    are readded to One-Click Search Engines

Latest regression form about few days.

I suspect that it can be caused by one of these bugs:
Bug #1496075 - Support loading search extensions on startup
Bug #1486820 - [meta] Convert builtin opensearch files to webextensions

@ Dale Harvey (:daleharvey) - Any ideas or it's missed call?

Flags: needinfo?(dharvey)
See Also: → 1544214
Summary: Amazon.com & Twitter & Wikipedia (en) are readded to One-Click Search Engines after each Mozilla Firefox update → Some One-Click Search Engines are constantly readded after each Mozilla Firefox update

Mozregression-GUI pointing me to:
bug #1496075 - Part 4: Delete searchplugins. r=mixedpuppy

Severity: normal → major
Has Regression Range: --- → yes
Regressed by: 1544214
Summary: Some One-Click Search Engines are constantly readded after each Mozilla Firefox update → Some One-Click Search Engines are constantly readded after each Mozilla Firefox update after landing patches from bug #1544214
Summary: Some One-Click Search Engines are constantly readded after each Mozilla Firefox update after landing patches from bug #1544214 → Some One-Click Search Engines are constantly readded after each Mozilla Firefox update after landing patches from bug #1496075
Assignee

Comment 4

2 months ago

Yeh this will almost certainly have been caused by my patches, taking a look

Assignee: nobody → dharvey
Flags: needinfo?(dharvey)

Comment 5

2 months ago

I posted this, yesterday, in Bug 1544214 but someone marked it as off topic and suggested this bug was more appropriate.

Just adding this. I'm in the RU region but I'm using the 'en-US' build of Nightly. Starting yesterday all search engines were removed and the address bar became unusable. After restarting the browser again some search engines were added: Bing, DDG, Wikipedia, Google, Twitter and Amazon.

Yesterday, I readded my chosen search engines, primarily from Mycroft but also two two from AMO but once again, following the earlier update today, everything was reset.

I also have the 'Automatically update search engines' option unchecked.

Mozregression:

Bug 1496075 - Part 4: Delete searchplugins. r=mixedpuppy
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=1a92c531a9af2815c1a8bb79716f0dd9d8b883a8&tochange=7e886806ae987d8008486c878921a8a33329c55b

Component: Address Bar → Search
Priority: -- → P1
Assignee

Comment 6

2 months ago

Ok no longer have a failing test for this, my build had leftover engines in the objdir which broke the test.

I deleted some builtin engines last week and have done 3/4 updates since then and not had them restored, I think this may have been fallout from the various invalid engines bugs

Pulse, Virtual_ManPL, can you still reproduce this bug? if so if you could post the logs of it happening with browser.search.log=true please? Thank you

Flags: needinfo?(ausaitis)
Flags: needinfo?(Virtual)

Comment 7

2 months ago

(In reply to Dale Harvey (:daleharvey) from comment #6)

Ok no longer have a failing test for this, my build had leftover engines in the objdir which broke the test.

I deleted some builtin engines last week and have done 3/4 updates since then and not had them restored, I think this may have been fallout from the various invalid engines bugs

Pulse, Virtual_ManPL, can you still reproduce this bug? if so if you could post the logs of it happening with browser.search.log=true please? Thank you

@Dale

Search engines are not being replaced for me either. I hadn't noticed before because i tend to use my own engines and disable update.

Here's a the logs from a new profile with several engines removed - https://pastebin.com/8FFF5DRV

Flags: needinfo?(ausaitis)

I also can't reproduce it anymore, since Mozilla Firefox Nightly 68.0a1 (2019-04-24). Looking on landed bugs and patches, looks like probably patch from bug #1544392 fixed this issue.

Thank you very much! \o/

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Depends on: 1544392
Flags: needinfo?(Virtual)
Resolution: --- → FIXED
Whiteboard: [fixed by patch backout from bug #1544392]
Status: RESOLVED → VERIFIED
Whiteboard: [fixed by patch backout from bug #1544392] → [fixed by patch from bug #1544392]

Hmm, odd, in latest Mozilla Firefox Nightly 68.0a1 (2019-04-26) (64-bit) [ https://hg.mozilla.org/mozilla-central/rev/b13f2b24ae625d16fdeeb61cdec10978c3c75638 ] update I can still reproduce this issue, so I'm reopening this bug.

@ Dale Harvey (:daleharvey) & Pulse - Could you also confirm this on your side?

Status: VERIFIED → REOPENED
Flags: needinfo?(dharvey)
Flags: needinfo?(ausaitis)
Resolution: FIXED → ---
Whiteboard: [fixed by patch from bug #1544392]

FYI - I updated to latest Mozilla Firefox Nightly 68.0a1 (2019-04-27) (64-bit) [ https://hg.mozilla.org/mozilla-central/rev/7bdb46cc5ec6221c8df10f0a239dc4faf457488d ] and unfortunately it wasn't just one thing.

Status: REOPENED → ASSIGNED

I want to add that issue is still reproducible for me even in latest Mozilla Firefox Nightly 68.0a1 (2019-05-07) [ 63bc837753d653ab13635e432400c1b6d31d12ca ].

Assignee

Comment 13

Last month

Still trying to reproduce this, I had a false negative in my previous test. If you could possibly run with 'browser.log.enabled=true' and give me the log output of a restart where this occurs it would be extremely useful. Cheers

Flags: needinfo?(dharvey) → needinfo?(Virtual)
Posted image Browser Console.png (obsolete) —

I hope I understood it correctly.
I added "browser.log.enabled" boolean type preference with "true" value to about:config.

Flags: needinfo?(Virtual)
Assignee

Comment 16

Last month

Argh I need to be more careful when I share the pref name, I meant browser.search.log=true sorry (and thanks)

Flags: needinfo?(dharvey) → needinfo?(Virtual)
Posted file Browser Console.txt

Done, please have a look.

Attachment #9063546 - Attachment is obsolete: true
Attachment #9063547 - Attachment is obsolete: true
Flags: needinfo?(Virtual) → needinfo?(dharvey)

Comment 19

Last month
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2cd499a2a7d9
Ensure WebExtensionPolicy has started. r=aswan,Standard8

Comment 20

Last month
bugherder
Status: ASSIGNED → RESOLVED
Closed: 2 months agoLast month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee

Comment 21

27 days ago

Cheers for the log, see you in the new bug (clearing needinfo)

Flags: needinfo?(dharvey)

I'm marking this bug as VERIFIED and follow-up is being tracked in bug #1552559.

Status: RESOLVED → VERIFIED

Updated

26 days ago
Regressions: 1553202
You need to log in before you can comment on or make changes to this bug.