Closed Bug 1544435 Opened 5 months ago Closed 5 months ago

Crash in [@ @0x0 | wbload.dll | round]

Categories

(Core :: Graphics: WebRender, defect, P3, critical)

Other Branch
Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- wontfix
firefox68 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-836229e9-b264-4c20-8007-84a3a0190415.

Top 10 frames of crashing thread:

0  @0x0 
1 wbload.dll wbload.dll@0x10bf5 
2 xul.dll round 
3 xul.dll round 
4 xul.dll round 
5 xul.dll round 
6 d3d11.dll CSampler::GetDesc 
7 d3d11.dll CDevice::CreateQuery_Worker 
8  @0xffffffff 
9 mozglue.dll void* arena_t::MallocSmall memory/build/mozjemalloc.cpp:2776

It seems like with WR enabled we are getting quite a few crashes with this wbload.dll thing, which is part of WindowBlinds. I'm assuming that when this crash happens we just disable the GPU process (and WR) and go back to basic, so it's not the end of the world, but it would be nice if we could either fix it on our side, or suggest something to Stardock to fix it on their end.

Blocks: wr-stability
Priority: -- → P3
See Also: → 1477447

Thanks, I had forgotten about that bug. Per the discussion in bug 1477447 comment 12 onwards, it looks like the crash is basically the same as was happening back then, and we do end up disabling the GPU process after four crashes and falling back to Basic. The fallback seems to work well so that's good. Also good is that since each startup will generate four crash reports we should be able to ignore 75% of these crash reports which makes the effective volume much lower.

But we should still track this and maybe try to come up with some way to fix it.

This is the top non-hang Windows crash for the 4/24 Nightlies.

Maybe Aaron has some ideas on what could be the next step here?

Flags: needinfo?(aklotz)

I actually thought we blocked wbload.dll from loading. Maybe we could just do that?

It's not listed in mozglue/build/WindowsDllBlocklistDefs.h which appears to be the DLL blocklist. I can add it although I have no idea what I'm doing :)

Assignee: nobody → kats
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6d4fe74b51ca
Block wbload.dll as it causes GPU process crashes. r=aklotz
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Flags: needinfo?(aklotz)
Duplicate of this bug: 1523180
Duplicate of this bug: 1530141
Crash Signature: [@ @0x0 | wbload.dll | round] → [@ @0x0 | wbload.dll | round] [@ @0x0 | wbload.dll | gl::ActiveTexture ] [@ @0x0 | wbload.dll | trunc | trunc | trunc | trunc | trunc | CSampler::GetDesc ] [@ @0x0 | wbload.dll | trunc | trunc | trunc | trunc | CSampler::GetDesc ] [@ @0x0 | wbload.dll…
Crash Signature: wbload.dll | arena_t::DallocSmall | CDevice::CreateQuery_Worker ] [@ @0x0 | wbload.dll | igd10umd64.dll | trunc | CDevice::CreateQuery_Worker ] → wbload.dll | arena_t::DallocSmall | CDevice::CreateQuery_Worker ] [@ @0x0 | wbload.dll | igd10umd64.dll | trunc | CDevice::CreateQuery_Worker ] [@ @0x0 | wbload.dll | trunc | CSampler::GetDesc]
Crash Signature: wbload.dll | arena_t::DallocSmall | CDevice::CreateQuery_Worker ] [@ @0x0 | wbload.dll | igd10umd64.dll | trunc | CDevice::CreateQuery_Worker ] [@ @0x0 | wbload.dll | trunc | CSampler::GetDesc] → wbload.dll | arena_t::DallocSmall | CDevice::CreateQuery_Worker ] [@ @0x0 | wbload.dll | igd10umd64.dll | trunc | CDevice::CreateQuery_Worker ] [@ @0x0 | wbload.dll | trunc | CSampler::GetDesc] [@ @0x0 | wbload.dll | trunc] [@ @0x0 | wbload.dll | trunc …
Crash Signature: wbload.dll | arena_t::DallocSmall | CDevice::CreateQuery_Worker ] [@ @0x0 | wbload.dll | igd10umd64.dll | trunc | CDevice::CreateQuery_Worker ] [@ @0x0 | wbload.dll | trunc | CSampler::GetDesc] [@ @0x0 | wbload.dll | trunc] [@ @0x0 | wbload.dll | trunc … → wbload.dll | arena_t::DallocSmall | CDevice::CreateQuery_Worker ] [@ @0x0 | wbload.dll | igd10umd64.dll | trunc | CDevice::CreateQuery_Worker ] [@ @0x0 | wbload.dll | trunc | CSampler::GetDesc] [@ @0x0 | wbload.dll | trunc] [@ @0x0 | wbload.dll | tru…

P3, low level of crashes, wontfix for 67.

Duplicate of this bug: 1298221
Crash Signature: je_malloc | nvwgf2umx_cfg.dll | CSampler::GetDesc ] → je_malloc | nvwgf2umx_cfg.dll | CSampler::GetDesc ] [@ wbload.dll@0x11838] [@ wbload.dll@0x14d98] [@ wbload.dll@0x14df8] [@ wbload.dll@0x151f8] [@ wbload.dll@0x1a314] [@ wbload.dll@0x1ad04] [@ wbload.dll@0x1b38d] [@ wbload.dll@0x1e2ac] [@ wbload.dll@0x1f…
You need to log in before you can comment on or make changes to this bug.