Crash in [@ mozilla::net::LoadInfo::LoadInfo]

RESOLVED FIXED

Status

()

defect
P1
critical
RESOLVED FIXED
2 months ago
20 days ago

People

(Reporter: calixte, Assigned: mayhemer)

Tracking

(Blocks 1 bug, Regression, {crash, regression, topcrash})

Trunk
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68+ fixed)

Details

(Whiteboard: [necko-triaged], crash signature)

Attachments

(1 obsolete attachment)

Reporter

Description

2 months ago

This bug is for crash report bp-38cbb461-b358-463c-a76a-d7dde0190417.

Top 10 frames of crashing thread:

0 xul.dll mozilla::net::LoadInfo::LoadInfo netwerk/base/LoadInfo.cpp:290
1 xul.dll nsresult mozilla::net::nsIOService::NewChannelFromURIWithProxyFlagsInternal netwerk/base/nsIOService.cpp:907
2 xul.dll nsresult mozilla::net::nsIOService::NewChannelFromURIWithClientAndController netwerk/base/nsIOService.cpp:868
3 xul.dll NS_NewChannelInternal netwerk/base/nsNetUtil.cpp:370
4 xul.dll NS_NewChannel netwerk/base/nsNetUtil.cpp:313
5 xul.dll void mozilla::net::nsHttpChannel::PerformBackgroundCacheRevalidationNow netwerk/protocol/http/nsHttpChannel.cpp:10318
6 xul.dll nsresult mozilla::detail::RunnableMethodImpl<mozilla::net::nsHttpChannel*, void  xpcom/threads/nsThreadUtils.h:1174
7 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1180
8 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:486
9 xul.dll void mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:88

There are 18 crashes (from 11 installations) in nightly 68 with buildid 20190416220148. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1536511.

[1] https://hg.mozilla.org/mozilla-central/rev?node=728aa342ad35

Flags: needinfo?(honzab.moz)

Comment 1

2 months ago

Crash report from macOS 10.11.6:
https://crash-stats.mozilla.org/report/index/a0983ea3-45db-4931-94cb-8b5cd0190417

Firefox crashes every time when trying to load https://www.ghacks.net. I wasn't able to reproduce the crash on other websites.

Assignee

Updated

2 months ago
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Priority: -- → P1
Whiteboard: [necko-triaged]

[Tracking Requested - why for this release]: #1 non-shutdown hang crash on Windows for the 3/17 Nightlies.

Keywords: topcrash

Updated

2 months ago
Duplicate of this bug: 1545929

Updated

2 months ago
Duplicate of this bug: 1545944

This is the #2 topcrash in the Windows nightly 20190418221600,
with 82 crashes from what looks like a significantly large number
of different installations.

Comment hidden (Intermittent Failures Robot)

Comment 9

2 months ago

Seems to rather major bug, maybe commit in 1536511 should be reverted?

Boris, it'd be great to have this reviewed and fixed asap. Thanks!

Flags: needinfo?(bzbarsky)
Reporter

Comment 11

2 months ago

The patch in bug 1536511 has been backed out.

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Flags: needinfo?(bzbarsky)
Attachment #9059030 - Attachment is obsolete: true

Sorry for the lag here; I was out most of last week...

(In reply to Calixte Denizet (:calixte) from comment #11)

The patch in bug 1536511 has been backed out.

How sure are we that this fixed the crash? I just hit this crash in the latest nightly [EDIT: turns out I wasn't running latest nightly, sorry for my confusion]
bp-d4e3019b-f1af-4afa-8221-9d4e20190423
bp-e1d1dc02-c3dc-4af2-847a-1d7d20190423

My STR:
(1) Visit https://imgur.com/gallery/dSYAaEb
(2) Save the page in Pocket (click the pocket icon at right edge of URLbar)
(3) Visit https://app.getpocket.com/ and click the new tile that you just created there ("tl;dw Game of Thrones Season 8, Episode 2 Recap - Album on Imgur")

Results:
crash [@ mozilla::net::LoadInfo::LoadInfo ], see bp-*** report links above.

Flags: needinfo?(cdenizet)
Reporter

Comment 14

2 months ago

:dholbert, the first report has buildid 20190418221600 and the second 20190417214729 and the first build with the backout is 20190422214919.
Fyi, if you've a look on the crash table on the top of this page, you can see that builds after 20190422214919 (included) don't have (at least for now) any crashes with this signature.

Flags: needinfo?(cdenizet)

Ah, thank you & sorry for my confusion/false-alarm. Indeed, latest nightly doesn't crash after all, with my STR.

(In comment 13, I had only verified that I was on latest nightly [via Help|About] after I'd crashed twice -- and it seems I'd been initially running an old build, with an old-update staged to install, which is why I was still on an old version in my second crash. Each post-crash browser-restart got me a tick closer to the latest version.)

You need to log in before you can comment on or make changes to this bug.