implement Create Desktop Shortcut in context menu

RESOLVED WONTFIX

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED WONTFIX
16 years ago
7 years ago

People

(Reporter: sairuh (rarely reading bugmail), Unassigned)

Tracking

Trunk
x86
Windows 2000
Dependency tree / graph
Bug Flags:
blocking-seamonkey2.0a1 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
funny, i had thought this was either being tracked for implementation...or
already implemented. couldn't find it in current or older builds or an existing
bug. eh well!

anyhow, for the context area context menus on win32, there should be a "create
desktop shortcut", according to the spec:

http://mozilla.org/projects/ui/communicator/framework/contextmenus/index.html#Anchor-28258
(Reporter)

Updated

16 years ago
Blocks: 135841
QA Contact: paw → sairuh

Comment 1

16 years ago
oh god no

Comment 2

16 years ago
A very important omission.

Comment 3

16 years ago
related: bug 156681
at least this bug is not as lame as bug 156681 is...
Severity: normal → enhancement

Comment 4

15 years ago
*** Bug 156681 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
Count my vote on this too. :o)

Btw: I thought this was being worked on!. I've been asking for this feature ever
since the Mozilla 0.94 days... and my netscape friends have been promising this
feature will be back "soon" ever since Netscape 6.01 ...

:-/

Hopefully this would be trivial to implement... compared to the neverending
DHTML performance bugs... ;-)

And btw: before someone suggests ("why don't you drag and drop the url icon...")
let me tell you that I run my browser maximized, and often in full-screen mode.

Just my $0.02

Comment 6

15 years ago
Why is this worded as a request for a context menu item?  It's not context
sensitive, and it isn't even in the menubar menus yet.

Comment 7

15 years ago
It is a context menu item most likely because the old versions < 5 of Netscape
that had the ability to create shortcuts, for example, 4.77, only had this
ability in the context menu.  Using current and old versions of IE are
consistent with Netscape in this regard.  You can only create an internet
shortcut through the context menu.  I don't know of any browsers offhand where
you can select create shortcut as a menu item, nor do I know of anyone who is
used to using the menubar menus to create a shortcut.  Because of this, putting
it into the File menu before the context menu may prove counter-intuitive.

Comment 8

15 years ago
This is the only thing keeping me from deleting the IE icon off my desktop. 
Whenever I want to send a shortcut of a page to my desktop I have to use IE.
(Then run Ad Aware to get rid of all the cookies IE picked up in the process.)

Please add this feature. =)

Comment 9

15 years ago
Workaround A:
1. Unmaximize the Mozilla window.
2. Make sure the right part of the desktop is showing.
3. Drag to the desktop.

Workaround B:
1. Start dragging.
2. Press StartKey+D.
3. Finish dragging.

Comment 10

15 years ago
Workaround C:
1. Drag URL icon to a blank area on the Windows taskbar.
2. Wait for the desktop to appear.
3. Drop shortcut on desktop.

(Workaround B can be difficult on laptops--WinKey may be opposite corner of D-key)
Product: Core → Mozilla Application Suite

Updated

13 years ago
Blocks: 164421
Assignee: bross2 → guifeatures
QA Contact: bugzilla

Comment 11

11 years ago
There has long been available an extension called "Deskcut" that performs this function.  It would be good to incorporate it into Firefox itself, in case the developer of Deskcut does not keep issuing new versions as necessary.

Deskcut is available at https://addons.mozilla.org/en-US/firefox/addon/66

Comment 12

10 years ago
This sounds fairly simple. Just take the existing code patch and build it into the program. 
Flags: blocking-seamonkey2.0a1?

Comment 13

10 years ago
not going to block anything... in fact, I can't imagine why we'd do this.
==> WONTFIX
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-seamonkey2.0a1? → blocking-seamonkey2.0a1-
Resolution: --- → WONTFIX
(In reply to comment #13)
> in fact, I can't imagine why we'd do this. 

OS integration? Easy of use? Ease of migration? Just because it's a Windows-only feature there's no reason to immediately dismiss it. Is there a real reason to not do this?

Comment 15

10 years ago
It's not particularly useful -- there are other (more intuitive) ways to do what you want.  The context menu should only contain the most appropriate and useful items.

Comment 16

10 years ago
It's useful to those of us who use it.  I use the deskcut extension dozens of times per day.  I put the shortcuts on my desktop for pages I need to refer to soon and then move them to relevant folders.  

The drag and drop options are tedious if you use this feature a lot and have your browser maximized or the desktop obscured by many open windows.

Whether this item is in the context menu or elsewhere is not crucial to me. I would be fine with having it in the file menu or the bookmark menu; but historically it has been in the context menu.

(While I'm on the topic, ideally I'd like to have a "save shortcut" item which opens a "save as" type box that allows you to choose the folder where you will put the shortcut.  This could even be put in as a modification of the "save page as" dialog.  In addition to being able to save a page as "html only" or "complete" you could have the option to save it as a shortcut.)





Comment 17

10 years ago
How about putting it in the bookmark menu? It would sure be handy to have this ability easily accessible.

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design

Updated

7 years ago
Duplicate of this bug: 627990
You need to log in before you can comment on or make changes to this bug.