Add a checkbox in prefs to enable/disable password generation

VERIFIED FIXED in Firefox 69

Status

()

enhancement
P2
normal
VERIFIED FIXED
4 months ago
25 days ago

People

(Reporter: MattN, Assigned: sfoster)

Tracking

(Blocks 1 bug)

Trunk
mozilla69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox69 verified)

Details

(Whiteboard: [passwords:generation] [skyline])

User Story

If the password manager is unchecked in preferences, the password generation checkbox should be disabled to reflect that they work together.
The generation checkbox should probably be indented underneath it.
If `signon.generation.available` is false then the checkbox should be hidden altogether.

Attachments

(2 attachments, 1 obsolete attachment)

Users need a way to enable/disable password generation

Flags: qe-verify+

This is blocked on getting copy for the checkbox label.

Flags: needinfo?(ssage)

Hi Betsy,

My understanding is that you will be helping with copy for password generation. Could you please review the string for the new checkbox? it will turn on/off whether generated passwords will be offered to the user in the autocomplete popup on a password field. I think the checkbox should be nested under the "Remember logins and passwords for sites" checkbox since it will only work if that is also on… that does cause an issue with the "Saved Logins…" button placement though…

I think the "new accounts" aspect of the proposed string from the mock isn't great since we will also generate passwords on password change forms which are for existing accounts.

Thank you

Flags: needinfo?(ssage) → needinfo?(bmikel)

String should read: Suggest and generate strong passwords.

Here's a rough mock-up to show what all the final strings should look like together, since the previous screenshot pre-dates some other string changes.

Flags: needinfo?(bmikel)

Thank you Betsy!

Attachment #9068224 - Attachment is obsolete: true
User Story: (updated)
User Story: (updated)
  • Add password generation checkbox as child of savePasswords checkbox
  • Shuffle layout to put the Exceptions and Saved Logins buttons in a right-column
  • Fix browser_site_login_exceptions.js which apparently relies on signon.rememberSignons being false
  • No changes related to bug 1550142 in this patch
Attachment #9071141 - Attachment description: Bug 1548387 - Add UI for the password generation preferences. r?MattN,flod → Bug 1548387 - Add UI for the password generation preferences. r?jaws
Assignee: nobody → sfoster
Status: NEW → ASSIGNED
Attachment #9071141 - Attachment description: Bug 1548387 - Add UI for the password generation preferences. r?jaws → Bug 1548387 - Add UI for the password generation preferences. r?MattN
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/56d2a86214e1
Add UI for the password generation preferences. r=MattN,flod,fluent-reviewers
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Is there another bug for shipping this default on or default off in 70/Skyline?

Flags: needinfo?(sfoster)
Whiteboard: [skyline]
Whiteboard: [skyline] → [passwords:generation] [skyline]

(In reply to Liz Henry (:lizzard) (use needinfo) from comment #9)

Is there another bug for shipping this default on or default off in 70/Skyline?

We're turning on both prefs by default in bug 1565407.

Flags: needinfo?(sfoster)

Addition confirmed with 69.0b7 on Windows 10, macOS 10.14, Ubuntu 18.04.
Option marked as: Suggest and generate strong passwords.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.