Homepage link on the global header is wrong

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
3 months ago
Last month

People

(Reporter: kohei, Assigned: dylan)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

STR:

  1. Open the Enter Bug page
  2. Click the Bugzilla homepage on the global header

Expected: It takes you to the homepage

Actual: The page reloads.

Culprit:

<a href="[% c.url_for('/home').to_abs FILTER html %]" title="Go to home page">

Side note: The announcement banner hidden on another page also appears.

Maybe enter_bug.cgi is not under control of Mojolicious?

Flags: needinfo?(dylan)
  if (($ENV{SERVER_SOFTWARE} // '') eq 'Bugzilla::App::CGI') {
    $vars->{self} = $vars->{c} = $Bugzilla::App::CGI::C;
  }

Something is probably overwriting 'c'. I hate this template language so much, I wish everything was just mojo's template language (which is just perl but prevents this sort of footgun)

Flags: needinfo?(dylan)
Assignee: nobody → dylan

Ah okay, found the culprit. Then this is a variant of Bug 1514275.

Merged to master.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Summary: Homepage link on the global header is wrong (only on the Enter Bug page?) → Homepage link on the global header is wrong
Duplicate of this bug: 1552829
You need to log in before you can comment on or make changes to this bug.