Closed Bug 1549727 Opened 1 year ago Closed 1 year ago

The page shifts slightly to the left after dismissing the onboarding modal

Categories

(Firefox :: Messaging System, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 68
Iteration:
68.4 - Apr 29 - May 12
Tracking Status
firefox66 --- unaffected
firefox67 --- verified
firefox68 --- verified

People

(Reporter: cmuresan, Assigned: rrosario)

References

Details

(Keywords: github-merged)

Attachments

(1 file)

[Affected versions]:

  • Firefox Nightly 68.0a1, Build ID 20190507094727

[Affected Platforms]:

  • All Windows
  • All Mac
  • All Linux

[Steps to reproduce]:

  1. Start the browser with a new profile and navigate to about:welcome.
  2. Observe the page as you dismiss the modal.

[Expected results]:

  • The page remains in the same place.

[Actual results]:

  • The page shifts slightly to the left after the modal is dismissed.

[Notes]:

  • It looks like this is related to the fact that while the modal is displayed the page does not have a scrollbar. And when the modal is dismissed the page has a scrollbar and this moves all the elements to the left.
  • The issue is also reproducible with the "sync" modal.
  • Attached a screen recording of the issue: Link.

aaron, what

Priority: -- → P3

In bug 1549714, our fix changed height breakpoint to 760px and width breakpoint to 924px to show scrollbars (and push the modal up slightly). Given that those breakpoints seem somewhat large, should we just always allow the page to be scrolled (and maybe remove the "push up modal" behavior) ?

See Also: → 1549714
Assignee: nobody → rrosario

UX/Aaron gave us the go to always be scrolling.

Iteration: --- → 68.4 - Apr 29 - May 12
Blocks: 1550300
Keywords: github-merged
Priority: P3 → P1
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

I have verified that the issue is no longer reproducible on the latest Nightly 68.0a1 (Build ID 20190509033505) on Windows 10x64, Mac 10.14, and Arch Linux 4.14.3.

Status: RESOLVED → VERIFIED

Marking verified as per bug 1550098 Comment 13 for bugs that were status-firefox68=verified

Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.