Closed Bug 1550053 Opened 1 year ago Closed 1 year ago

DS sequential load broke filtering out topsites or topstories

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 68
Iteration:
68.4 - Apr 29 - May 12
Tracking Status
firefox68 --- verified

People

(Reporter: thecount, Assigned: thecount)

References

(Regression)

Details

(Keywords: github-merged)

Attachments

(1 file)

I think I have a fix incoming, but basically, if you disable topsites or topstores, you get a broken experience.

In the case of topsites disabled, you get "Oops, something went wrong loading this content.
Refresh page to try again"

If you disabled topstores, you get a half rendered page, with a title for pocket stories then no pocket stories.

Blocks: 1550300
Iteration: --- → 68.4 - Apr 29 - May 12
Keywords: github-merged
Priority: -- → P1
Duplicate of this bug: 1550464
Duplicate of this bug: 1550447
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee: nobody → sdowne

I have verified that the issue is no longer reproducible on the latest Nightly 68.0a1 (Build ID 20190509033505) on Windows 10x64, Mac 10.14, and Arch Linux 4.14.3. The experience is no longer broken if one of the sections is disabled.

Status: RESOLVED → VERIFIED
Regressed by: 1548329
Regressions: 1552237
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.