Closed Bug 1552120 Opened 7 months ago Closed 6 months ago

Deleted search extensions are not rebuilt

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: daleharvey, Assigned: chmanchester)

References

(Blocks 2 open bugs)

Details

(Keywords: in-triage)

Attachments

(1 file)

Will follow up with proper STR, however I have noticed when search extensions (https://searchfox.org/mozilla-central/source/browser/components/search/extensions) are changed, particularly deleted then the we run in issues until I fine and delete all "search-extensions" folders in my objdir

I think this is probably very similar to, or the same as bug 1500924 - see especially bug 1500924 comment 6 and onwards.

Depends on: 1500924
Keywords: in-triage

I can replicate a failure here by trying to package after updating across 1f482a604473, indeed the problem is broken symlinks. This is sort of a known problem with JarMaker (see bug 1394576 and bug 1297381). If I use an artifact build it works fine as install manifests are used there instead of JarMaker.

Ultimately we want to use install manifests for this, but in the meantime I have a patch that adds a flag to the packager to ignore broken symlinks for developer builds. It's not ideal but I don't think it's a regression from what we have and should keep people from wasting time with this problem.

Assignee: nobody → cmanchester

Maybe we should just use install manifests when not doing l10n (because that's basically the only reason we don't use install manifests).

(as in, when --with-l10n-base is not passed)

(In reply to Mike Hommey [:glandium] from comment #4)

Maybe we should just use install manifests when not doing l10n (because that's basically the only reason we don't use install manifests).

That's probably more than I can take on right now, but if you have a work in progress somewhere I'd take a look at that.

Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3b3197edd96a
Add a flag to the packager to ignore broken symlinks and pass it for developer builds. r=firefox-build-system-reviewers,mshal
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.