proxy.onRequest is limited to http/https

RESOLVED FIXED in Firefox 68

Status

defect
P1
normal
RESOLVED FIXED
Last month
5 days ago

People

(Reporter: mixedpuppy, Assigned: mixedpuppy, NeedInfo)

Tracking

(Blocks 2 bugs, {regression})

unspecified
mozilla69
Dependency tree / graph
Bug Flags:
in-testsuite +
qe-verify -

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 wontfix, firefox68+ fixed, firefox69 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

Last month

onRequest is using ChannelWrapper.matches which is not matching ftp. This is verified, investigating more.

Assignee

Updated

Last month
Blocks: 1545411
Assignee

Comment 1

Last month

ChannelWrapper is used throughout webext APIs and it requires a channel to support weakref.
FTPChannel did not, thus ftp requests did not go through proxy.onRequest.

Assignee

Comment 2

Last month

Bug 1525447 regressed proxy.register so ftp urls will not work. The regression starts with 67.

Keywords: regression
Regressions: 1525447

Tracking 68 as this is blocking bug 1545411 which targets 68. Too late to fix in 67 as we already built RC2, so marking as wontfix for 67. Shane if you feel that this should be a dot release driver post 67 or a strong candidate for a ride-along, please tell me, thanks.

Assignee

Comment 4

27 days ago

Pascal: Can we make this a ride-along for 67? I'm not sure how to mark the bug for that.

I'm going to have to request uplift to 68 since it's landing on 69.

Flags: needinfo?(pascalc)

Comment 5

27 days ago
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c50b4c90d56a
support ftp channel in proxy api r=mayhemer,kmag

Comment 6

27 days ago
bugherder
Status: NEW → RESOLVED
Closed: 27 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Assignee

Comment 7

26 days ago

Comment on attachment 9065543 [details]
Bug 1552248 support ftp channel in proxy api

Beta/Release Uplift Approval Request

  • User impact if declined: ftp requests no longer go through the proxy api
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce: The automated tests should be enough, but you can produce a simple extension based on the test added in the patch to test that ftp will proxy. You'll need access to an ftp proxy server.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The running code change here simply adds the nsISupportsWeakReference interface to the ftp channel. This enables an ftp request to be used within the extension ChannelWrapper, allowing the request to work again in proxy and some limited webrequest APIs (which was also broke when we introduced ChannelWrapper).
  • String changes made/needed: none
Attachment #9065543 - Flags: approval-mozilla-beta?
Flags: in-testsuite+

Comment on attachment 9065543 [details]
Bug 1552248 support ftp channel in proxy api

approved for 68.0b4.

Attachment #9065543 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.