Last Comment Bug 15529 - some files in js/src have no license boilerplate at all
: some files in js/src have no license boilerplate at all
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Linux
P3 normal (vote)
: mozilla1.0.1
Assigned To: Luke Wagner [:luke]
:
: Jason Orendorff [:jorendorff]
Mentors:
: 15528 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-04 18:21 PDT by Dan Mosedale (:dmose)
Modified: 2011-06-21 17:41 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
list of files which probably require updates (6.50 KB, text/plain)
1999-10-04 18:23 PDT, Dan Mosedale (:dmose)
no flags Details
2nd try at files needing boilerplate run against clean tree (4.73 KB, text/plain)
1999-10-04 18:58 PDT, Dan Mosedale (:dmose)
no flags Details
Updated list of files in js/src that are missing licenses (330 bytes, text/plain)
2004-05-29 13:14 PDT, Sterling Bates
no flags Details
remove unused files (13.31 KB, patch)
2011-06-17 16:06 PDT, Luke Wagner [:luke]
brendan: review+
Details | Diff | Splinter Review
get jimb's approval for adding standard copyright to file he committed (2.07 KB, patch)
2011-06-17 16:07 PDT, Luke Wagner [:luke]
jimb: review+
Details | Diff | Splinter Review
get graydon's approval for adding standard copyright to file he committed (2.19 KB, patch)
2011-06-17 16:08 PDT, Luke Wagner [:luke]
graydon: review+
Details | Diff | Splinter Review

Description User image Dan Mosedale (:dmose) 1999-10-04 18:21:56 PDT
These files need to be updated with appropriate boilerplate from
<http://www.mozilla.org/MPL/boilerplate-1.1/>.
Comment 1 User image Dan Mosedale (:dmose) 1999-10-04 18:23:59 PDT
Created attachment 1982 [details]
list of files which probably require updates
Comment 2 User image Mike McCabe 1999-10-04 18:29:59 PDT
A number of files in this list appear to be files generated during the build
process.    We do seem to be missing some licenses, but a run of your
license-testing tool on a clean tree will probably yield a clearer picture of
just what we need.
Comment 3 User image Mike McCabe 1999-10-04 18:30:59 PDT
*** Bug 15528 has been marked as a duplicate of this bug. ***
Comment 4 User image Dan Mosedale (:dmose) 1999-10-04 18:50:59 PDT
Right you are; I'll generate another list.
Comment 5 User image Dan Mosedale (:dmose) 1999-10-04 18:58:59 PDT
Created attachment 1984 [details]
2nd try at files needing boilerplate run against clean tree
Comment 6 User image Mike McCabe 1999-10-28 16:11:59 PDT
Roger, can you handle this?
Comment 7 User image rogerl (gone) 2000-01-12 17:09:59 PST
Not going to make M13 for these.
Comment 8 User image leger 2000-02-03 18:01:10 PST
Setting all Javacript bugs to rginda QA Contact.
Comment 9 User image rogerl (gone) 2000-02-16 10:27:32 PST
Got a bunch done already, working on the rest, but not for M14 anymore.
Comment 10 User image rogerl (gone) 2000-05-05 18:12:21 PDT
Patrick made me do this ... would you mind taking a look at the list of files 
attached (there's also a pointer to some guidelines on boilerplates) and see 
whats left to be done here. Thanks
Comment 11 User image Oliver Klee 2001-02-20 10:56:21 PST
Milestone 0.8 has been released. We should either resolve this bug or update its
milestone.
Comment 12 User image Phil Schwartau 2001-02-20 13:01:50 PST
Updating milestone - low-priority, but should be able to get to this shortly - 
my apologies.
Comment 13 User image Phil Schwartau 2001-04-16 19:59:48 PDT
Moving out to mozilla1.0 milestone - 
Comment 14 User image Asa Dotzler [:asa] 2001-12-03 11:06:11 PST
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Comment 15 User image Sterling Bates 2004-05-29 13:14:50 PDT
Created attachment 149596 [details]
Updated list of files in js/src that are missing licenses

Not sure if this bug needs this, but I've updated the list of files that I
noticed do not have licenses.  I excluded autogenerated files and binaries.
Comment 16 User image Luke Wagner [:luke] 2011-06-17 16:06:25 PDT
Created attachment 540170 [details] [diff] [review]
remove unused files

In addition to not having license boilerplate, these files seem to be totally unused, so might as well remove.
Comment 17 User image Luke Wagner [:luke] 2011-06-17 16:07:32 PDT
Created attachment 540172 [details] [diff] [review]
get jimb's approval for adding standard copyright to file he committed
Comment 18 User image Luke Wagner [:luke] 2011-06-17 16:08:16 PDT
Created attachment 540173 [details] [diff] [review]
get graydon's approval for adding standard copyright to file he committed
Comment 19 User image Luke Wagner [:luke] 2011-06-17 16:10:52 PDT
With these changes,
  find . -maxdepth 1 -o -not -type d -print | xargs head -n 40
shows copyright blurbs for all files with the exception of Y.js which is not part of the build and more a test/amusement.
Comment 20 User image Graydon Hoare :graydon 2011-06-17 21:34:16 PDT
Comment on attachment 540173 [details] [diff] [review]
get graydon's approval for adding standard copyright to file he committed

If I wrote it moco owns the copyright anyways, so yes.
Comment 21 User image Mitchell Baker 2011-06-18 09:22:32 PDT
As a clarification:  the Mozilla Foundation owns the IP.  Fine (I think, I'll ask Harvey) for the copyright notice to identify the Mozilla Corporation as the Initial Developer; code and IP developed by MoCo is owned by the Foundation.
Comment 22 User image Brendan Eich [:brendan] 2011-06-20 17:02:15 PDT
Comment on attachment 540170 [details] [diff] [review]
remove unused files

I'm sentimental about perfect.js (it dates from 1995), but probably the right way to memorialize it is to make it a test -- r=me with that.

/be
Comment 23 User image Jim Blandy :jimb 2011-06-21 13:53:30 PDT
Comment on attachment 540172 [details] [diff] [review]
get jimb's approval for adding standard copyright to file he committed

Review of attachment 540172 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 24 User image Luke Wagner [:luke] 2011-06-21 14:35:20 PDT
http://hg.mozilla.org/mozilla-central/rev/5fe20ec0229c
with perfect.js moved to tests/
Comment 26 User image Luke Wagner [:luke] 2011-06-21 17:41:39 PDT
Apparently js/src/tests/perfect.js is too cute for the browser reftest harness (it worked in the shell harness).

http://hg.mozilla.org/mozilla-central/rev/56b2068a28ea

Note You need to log in before you can comment on or make changes to this bug.