Closed Bug 1553031 Opened 3 months ago Closed 3 months ago

[remote-dbg-next] remove "Remote Debugging" menu entry if new about:debugging is disabled

Categories

(DevTools :: about:debugging, task, P1)

task

Tracking

(firefox67 unaffected, firefox67.0.1 unaffected, firefox68 verified, firefox69 verified)

RESOLVED FIXED
Firefox 69
Tracking Status
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- verified
firefox69 --- verified

People

(Reporter: jdescottes, Assigned: jdescottes)

References

Details

(Whiteboard: [qa-triaged])

Attachments

(1 file)

We added a new menu entry "Remote Debugging" in the Tools > Developer menu, which leads to about:debugging#/setup. This menu item only makes sense if the new about:debugging is enabled.

We should hide this menu entry when the new about:debugging is disabled. This was a non-issue because remote debugging was supposed to ride the trains with 68, but it turns out we won't really ship in 68.

Note we used to have an alternate menu entry called "Service Workers", but I don't plan on bringing it back. Same for the WebIDE toolbar buttons.

Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3892b0290dbd
Hide Remote Debugging menu item when new aboutdebugging is disabled r=daisuke
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Comment on attachment 9066324 [details]
Bug 1553031 - Hide Remote Debugging menu item when new aboutdebugging is disabled

Beta/Release Uplift Approval Request

  • User impact if declined: It was decided to hold remote debugging in DevEdition until 69, due to lack of QA resources to perform a final QA sign off in Beta 68.
    This patch hides the context menu entry for Remote Debugging when the new remote debugging is not enabled
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: STRs:
  • open Firefox Beta with a clean profile (or set devtools.aboutdebugging.new-enabled to false and restart FF)
  • check the Tools > Web Developer menu
    Result with the patch: The menu should not show the item "Remote Debugging"
    Result without the patch: The menu shows an item "Remote Debugging"
  • List of other uplifts needed: Bug 1553028, Bug 1553029
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple javascript change, just reading a preference to decide to add a menu item or not.
  • String changes made/needed:
Attachment #9066324 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Whiteboard: [qa-triaged]

I've tested in the latest nightly 69.0a1 on several OS's: Windows 10, Ubuntu 18.04, Mac OS X.
On all cases having:

  • the option "devtools.aboutdebugging.new-enabled toggled to false" => the "Remote debugging" option from Tools won't appear among other items.
    -the option "devtools.aboutdebugging.new-enabled toggled to true" => the "Remote debugging" option from Tools will appear among other items.

Comment on attachment 9066324 [details]
Bug 1553031 - Hide Remote Debugging menu item when new aboutdebugging is disabled

approved for 68.0b4, thanks

Attachment #9066324 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I've tested in the latest FF -beta 68.0b4 on several OS's: Windows 10, Ubuntu 18.04, Mac OS X -> the results are the same as were explained at comment 5.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.