Address bar cannot find tagged bookmarks by tag

VERIFIED FIXED in Firefox 68

Status

()

defect
P1
normal
VERIFIED FIXED
2 months ago
17 hours ago

People

(Reporter: saadi.shamsaee, Assigned: mak)

Tracking

(Blocks 1 bug, Regression, Regressed 1 bug, {regression})

69 Branch
Firefox 69
Points:
3
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67 unaffected, firefox67.0.1 unaffected, firefox68 verified, firefox69 verified)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

i have bookmarked some webpages with tags,

Actual results:

when i enter the tag(s)(ie:firefox, nightly) in address bar, Firefox doesn't show the bookmarked page. however the many list items are empty still.

Expected results:

i want Firefox respect the tags, titles, and url, prioritizing in order. and be possible to change the prioritizing of these three in about:config.

Component: Untriaged → Address Bar

You can restrict the results to just bookmarks typing "*" or just tags typing "+", that should help with your search. The space is limited and it's hard to always get the perfect result set for all the users.

Looking at your specific case, do I understand correctly that the urlbar panel wasn't full (it had less then 10 results) but still your bookmark did not appear?
What did you type exactly? Which tags are set on that bookmark? We need a bit more detailed steps to reproduce your bug.

Flags: needinfo?(saadi.shamsaee)

it may also be useful to see a screenshot of the bookmark properties and one of the urlbar when you typed the tag, if possible.

(In reply to Marco Bonardo [::mak] from comment #1)

but still your bookmark did not appear?

What did you type exactly? Which tags are set on that bookmark? We need a bit more detailed steps to reproduce your bug.

no, my sightly bookmark didn't appear. you can see the bookmark in image:
[url=https://ibb.co/8YChDK9][img]https://i.ibb.co/J31hRBH/Untitled.jpg[/img][/url]

Flags: needinfo?(saadi.shamsaee)

Could you please also attach a urlbar screenshot when you try to search for it?

Flags: needinfo?(saadi.shamsaee)

https://ibb.co/jMDktKS

maybe Nightly 69 temporary is faulty. yea? and i did not understand that we can use * and + character for find aim bookmarks. thanks.

Flags: needinfo?(saadi.shamsaee)

if you type "firefox +" or "+ firefox" does the bookmark appear? I'm wondering if it's just a problem related to sorting results, or if it's not appearing at all.

not appear. just for this bookmark(https://calendar.google.com/........). but shows when i type a part of url or title.

i tested with other bookmarks. the problem is with tags.

Tags for bookmarks not work.

I cannot reproduce off-hand, even adding that same bookmark and those tags, but it's worth investigating this further, since it may be a QB regression.

Points: --- → 3
Priority: -- → P1

Drew, can you reproduce this bug?

Flags: needinfo?(adw)

after update to new nightly version, tag works by type "firefox" in last items of list(i prefer to be at top of list) , and doesn't find anything by "+ firefox" character.

(In reply to Saadi Shamsaee from comment #12)

(i prefer to be at top of list)

If you open Firefox's preferences, click the Search tab, and look for an option called "Show search suggestions ahead of browsing history in address bar results", is it checked? If so, try unchecking it. Although it looks from your screenshots that it might already be unchecked.

and doesn't find anything by "+ firefox" character.

Could you please open about:config, search for "browser.urlbar.quantumbar", set it to false, try again, and let us know whether it works?

Although iirc both awesomebar and quantumbar are using the same tokenizer now, so that might not tell us a whole lot.

Flags: needinfo?(adw) → needinfo?(saadi.shamsaee)

Forgot to say that I can't reproduce the problem either.

when "Show search suggestions ahead of browsing history in address bar results" is enabled not work without or with + . when i disable "Show search suggestions ahead of browsing history in address bar results" only works when i type "firefox" without +.

when "browser.urlbar.quantumbar" is disabled firefox works both of "firefox" and "+ firefox". practically the problem is with this config.

Flags: needinfo?(saadi.shamsaee)

Also, when "browser.urlbar.quantumbar" is disabled and "Show search suggestions ahead of browsing history in address bar results" is enabled, with "+" works but without "+" doesn't works and doesn't suggest the bookmarked page.

now works true! without any update. the "browser.urlbar.quantumbar" is disable still. i don't lie.

i enabled "browser.urlbar.quantumbar" again and now tag works in normal type, but doesnt work with "+ firefox".

another bug. "Mozilla" is a tag of a bookmark. when i type it the bookmark show, but when i type "mozilla" doesn't show. its case sensitive.

Summary: Address bar is weak in suggestion → Address bar cannot find tagged bookmarks by tag

I'll look again at this and try to see if I can figure out something.

Flags: needinfo?(mak77)

Actually, in a new profile I can reproduce the bug. Unless Dao has found some hints already, I should be able to work on this.

Assignee: nobody → mak77
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(mak77)

I actually found 2 bugs, that I think explain this. One is that UnifiedComplete returns "tag" style instead of "bookmark-tag" style when the "tag" behavior is forced through "+". The other one is that we filter tags in a case sensitive way in the provider, so the UI doesn't receive them.
I'll make a try build and ask you to test it, likely tomorrow.

This is a Try build, I suggest to make a backup of your profile before using it, in any case, of you can just try to copy your place.sqlite and prefs.js from your profile to a new one.
https://queue.taskcluster.net/v1/task/KMpRkVkyTD6Q8HJ4m0M2Yw/runs/0/artifacts/public/build/target.zip

Please let me know if this solves the problem, so I know I'm on the right way.

Flags: needinfo?(saadi.shamsaee)

yes, the problem is fixed in this build.

Flags: needinfo?(saadi.shamsaee)

Thank you for confirming, tomorrow I'll write tests and move on with this change

Iteration: --- → 69.2 - May 27 - Jun 9
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/956a54ed03c7
Quantum Bar may not return bookmark tags correctly. r=adw
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Comment on attachment 9067736 [details]
Bug 1553067 - Quantum Bar may not return bookmark tags correctly. r=adw

Beta/Release Uplift Approval Request

  • User impact if declined: Tagged bookmarks cannot be found properly in the address bar
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: In a new profile add a bookmark with tags "Firefox, Mozilla", try to search in the urlbar for "firefox" or "+ firefox" and find the tagged bookmark.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The fix is limited to minimum portions of the feature and simple, it has tests.
  • String changes made/needed: none
Attachment #9067736 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Keywords: regression
Regressed by: 1548031

I only managed to partially reproduce the issue. The only time when the older builds didn't find the bookmark was when I used "+". I tested this using Nightly from 2019-05-21 on Windows 10 x64.
I retested everything using the latest Nightly 69.0a1 on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64 and I can't reproduce the issue anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Duplicate of this bug: 1555898

Comment on attachment 9067736 [details]
Bug 1553067 - Quantum Bar may not return bookmark tags correctly. r=adw

quantumbar fix, approved for 68.0b7

Attachment #9067736 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

I verified the fix on beta 68.0b7 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13. The bug is not reproducing anymore.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.