Closed Bug 1553546 Opened 1 year ago Closed 8 months ago

Gather telemetry environment CPU and isWoW and installYear data off-main-thread and later on startup, off an idle task, instead of on the main thread during startup

Categories

(Toolkit :: Telemetry, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- fixed

People

(Reporter: Gijs, Assigned: emalysz)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxperf:p2] [fxperfsize:S])

Attachments

(1 file, 1 obsolete file)

All this data is currently fetched from the registry and/or file info, and we should ideally avoid doing this so early on startup.

Type: defect → enhancement
Priority: -- → P3
See Also: → 1554663
Assignee: nobody → emalysz
Blocks: 1579581
Attachment #9093613 - Attachment is obsolete: true
Attachment #9088314 - Attachment description: Bug 1553546, moving telemetry environment CPU, isWoW, and installYear data off-main-thread and implementing them on an idle task instead of on the main thread during startup → Bug 1553546, moving telemetry environment isWoW data and installYear data off-main-thread and implementing them on an idle task instead of on the main thread during startup
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d6dc4ad211f2
moving telemetry environment isWoW data and installYear data off-main-thread and implementing them on an idle task instead of on the main thread during startup r=mconley,chutten
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b295a3c77fb1
moving telemetry environment isWoW data and installYear data off-main-thread and implementing them on an idle task instead of on the main thread during startup r=mconley,chutten
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Flags: needinfo?(emalysz)
No longer blocks: 1619317
Regressions: 1619317
You need to log in before you can comment on or make changes to this bug.