Closed Bug 1553726 Opened 5 months ago Closed 5 months ago

Disable RDD Process for mingwclang build

Categories

(Firefox Build System :: General: Unsupported Platforms, task)

task
Not set

Tracking

(firefox68- fixed, firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox68 - fixed
firefox69 --- fixed

People

(Reporter: tjr, Assigned: tjr)

References

Details

Attachments

(1 file)

Until all the other bugs under Bug 1553720 are fixed, we should just disable this so Tor Browser doesn't have to remember to disable it.

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task

[Tracking Requested - why for this release]: The MinGW build for ESR 68 will need this.

Comment on attachment 9066929 [details]
Bug 1553726 - Disable the RDD process for MinGW builds until we can figure out the numerous failures r?drno

Beta/Release Uplift Approval Request

  • User impact if declined: Tor will need to carry the patch
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only affects MinGW build
  • String changes made/needed:
Attachment #9066929 - Flags: approval-mozilla-beta?

Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5de195a1e854
Disable the RDD process for MinGW builds until we can figure out the numerous failures r=mjf

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Comment on attachment 9066929 [details]
Bug 1553726 - Disable the RDD process for MinGW builds until we can figure out the numerous failures r?drno

mingwclang fix, for 68.0b6

Attachment #9066929 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

A note that this patch never had the intended effect because MINGW32 is not defined in the preference parser. However, it is only broken in 68 as Bug 1557844 fixed RDD for MinGW and is in the 69 branch. In Bug 1560183 we will re-enable RDD.

You need to log in before you can comment on or make changes to this bug.