Closed Bug 1555254 Opened 2 years ago Closed 2 years ago

Intermittent 0:33.85 TEST-UNEXPECTED-FAIL | No test output (missing mozunit.main() call?): z:\task_1559101992\build\src\testing\mozbase\mozdevice\tests\<test-name.py>

Categories

(Firefox for Android :: Testing, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1554186

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure, regression)

Filed by: csabou [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=248887193&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/SWHrLoSOQNmaX2Tit_9Fhg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-05-29T05:06:15.093Z] z:\task_1559101992\build\src\python\mozbuild\mozbuild\virtualenv.py:411: UserWarning: Hacking environment to allow binary Python extensions to build. You can make this warning go away by installing Visual Studio 2008. You can download the Express Edition installer from http://go.microsoft.com/?linkid=7729279
[task 2019-05-29T05:06:15.093Z] warnings.warn('Hacking environment to allow binary Python '
[task 2019-05-29T05:06:15.093Z] Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
[task 2019-05-29T05:06:21.624Z] Test configuration changed. Regenerating backend.
[task 2019-05-29T05:06:21.624Z] No build detected, test metadata may be incomplete.
[task 2019-05-29T05:06:21.624Z] 0:33.84 z:\task_1559101992\build\src\testing\mozbase\mozdevice\tests\test_chown.py
[task 2019-05-29T05:06:21.624Z] 0:33.84 Traceback (most recent call last):
[task 2019-05-29T05:06:21.625Z] 0:33.84 File "z:\task_1559101992\build\src\testing\mozbase\mozdevice\tests\test_chown.py", line 9, in <module>
[task 2019-05-29T05:06:21.626Z] 0:33.84 import mozunit
[task 2019-05-29T05:06:21.626Z] 0:33.84 File "z:\task_1559101992\build\src\build\mach_bootstrap.py", line 396, in call
[task 2019-05-29T05:06:21.627Z] 0:33.84 module = self.original_import(name, globals, locals, fromlist, level)
[task 2019-05-29T05:06:21.627Z] 0:33.84 File "z:\task_1559101992\build\src\config\mozunit\mozunit_init
.py", line 8, in <module>
[task 2019-05-29T05:06:21.627Z] 0:33.85 from .mozunit import *
[task 2019-05-29T05:06:21.627Z] 0:33.85 File "z:\task_1559101992\build\src\build\mach_bootstrap.py", line 396, in call
[task 2019-05-29T05:06:21.627Z] 0:33.85 module = self._original_import(name, globals, locals, fromlist, level)
[task 2019-05-29T05:06:21.627Z] 0:33.85 File "z:\task_1559101992\build\src\config\mozunit\mozunit\mozunit.py", line 12, in <module>
[task 2019-05-29T05:06:21.627Z] 0:33.85 import pytest
[task 2019-05-29T05:06:21.627Z] 0:33.85 File "z:\task_1559101992\build\src\build\mach_bootstrap.py", line 396, in call
[task 2019-05-29T05:06:21.627Z] 0:33.85 module = self._original_import(name, globals, locals, fromlist, level)
[task 2019-05-29T05:06:21.627Z] 0:33.85 File "z:\task_1559101992\build\src\third_party\python\pytest\src\pytest.py", line 9, in <module>
[task 2019-05-29T05:06:21.627Z] 0:33.85 from _pytest.config import main, UsageError, cmdline, hookspec, hookimpl
[task 2019-05-29T05:06:21.627Z] 0:33.85 File "z:\task_1559101992\build\src\build\mach_bootstrap.py", line 396, in call
[task 2019-05-29T05:06:21.627Z] 0:33.85 module = self.original_import(name, globals, locals, fromlist, level)
[task 2019-05-29T05:06:21.627Z] 0:33.85 File "z:\task_1559101992\build\src\third_party\python\pytest\src_pytest\config_init
.py", line 9, in <module>
[task 2019-05-29T05:06:21.627Z] 0:33.85 import six
[task 2019-05-29T05:06:21.627Z] 0:33.85 File "z:\task_1559101992\build\src\build\mach_bootstrap.py", line 396, in call
[task 2019-05-29T05:06:21.627Z] 0:33.85 module = self.original_import(name, globals, locals, fromlist, level)
[task 2019-05-29T05:06:21.627Z] 0:33.85 File "z:\task_1559101992\build\src\third_party\python\six\six.py", line 679, in <module>
[task 2019-05-29T05:06:21.628Z] 0:33.85 exec
= getattr(moves.builtins, "exec")
[task 2019-05-29T05:06:21.628Z] 0:33.85 File "z:\task_1559101992\build\src\third_party\python\six\six.py", line 92, in get
[task 2019-05-29T05:06:21.628Z] 0:33.85 result = self._resolve()
[task 2019-05-29T05:06:21.629Z] 0:33.85 File "z:\task_1559101992\build\src\third_party\python\six\six.py", line 115, in _resolve
[task 2019-05-29T05:06:21.630Z] 0:33.85 return _import_module(self.mod)
[task 2019-05-29T05:06:21.631Z] 0:33.85 File "z:\task_1559101992\build\src\third_party\python\six\six.py", line 82, in _import_module
[task 2019-05-29T05:06:21.631Z] 0:33.85 import(name)
[task 2019-05-29T05:06:21.631Z] 0:33.85 File "z:\task_1559101992\build\src\build\mach_bootstrap.py", line 396, in call
[task 2019-05-29T05:06:21.632Z] 0:33.85 module = self._original_import(name, globals, locals, fromlist, level)
[task 2019-05-29T05:06:21.632Z] 0:33.85 ValueError: level must be >= 0
[task 2019-05-29T05:06:21.632Z] 0:33.85 TEST-UNEXPECTED-FAIL | No test output (missing mozunit.main() call?): z:\task_1559101992\build\src\testing\mozbase\mozdevice\tests\test_chown.py
[task 2019-05-29T05:06:21.632Z] 0:33.85 Setting retcode to 1 from z:\task_1559101992\build\src\testing\mozbase\mozdevice\tests\test_chown.py
[task 2019-05-29T05:06:21.655Z] 0:33.87 z:\task_1559101992\build\src\testing\mozbase\mozcrash\tests\test_save_path.py

Pre-existing failure, not related to my push.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(gbrown)
No longer regressed by: 1555141
Resolution: --- → DUPLICATE
Duplicate of bug: 1554186
You need to log in before you can comment on or make changes to this bug.