Closed Bug 1556424 Opened 5 months ago Closed 5 months ago

Broken about:newtab and address bar

Categories

(Firefox :: Search, defect, P1)

defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 69
Iteration:
69.3 - Jun 10 - 23
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 + verified
firefox69 + verified

People

(Reporter: gerard-majax, Assigned: daleharvey)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

Since today's upgrade, I'm unable to browse to new pages.

STR:

  1. Open a new tab
  2. Notice the thumbnails are all broken
  3. Type address, hit enter

Expected:
Page loads

Actual:
Nothing

Attached file mozregression log
Has Regression Range: --- → yes
Keywords: regression
Regressed by: 1552559

Attached is a stack shown in JS Console, after opening a new (broken) tab, and after starting to type some data.

Also, the search engines are all missing from about:preferences.

Please can you set browser.search.log to true and restart Firefox, then copy the logs from the Browser Console and attach them here.

It may also be useful to know the value of your browser.search.region preference, and which locale of Firefox you are testing. Also if you have previously disabled any of the default search engines.

FWIW I'm not seeing any issues on my normal profile (en-GB, GB).

Flags: needinfo?(lissyx+mozillians)

(In reply to Mark Banner (:standard8) from comment #4)

Please can you set browser.search.log to true and restart Firefox, then copy the logs from the Browser Console and attach them here.

Will do.

It may also be useful to know the value of your browser.search.region preference, and which locale of Firefox you are testing. Also if you have previously disabled any of the default search engines.

browser.search.region=FR

Nightly fr-FR

FWIW I'm not seeing any issues on my normal profile (en-GB, GB).

Flags: needinfo?(lissyx+mozillians)

Here is what I get filtering on "search" in js console, after restarting with the log pref toggled:

SearchService.init
SearchService.init
ensureBuiltinExtension: google@search.mozilla.org
installExtensionEngine: google@search.mozilla.org
addEnginesFromExtension: installing locale: google@search.mozilla.org:b-d
SearchService.init
ensureBuiltinExtension: google@search.mozilla.org installed.
ensureBuiltinExtension: bing@search.mozilla.org
installExtensionEngine: bing@search.mozilla.org
addEnginesFromExtension: installing locale: bing@search.mozilla.org:default
ensureBuiltinExtension: bing@search.mozilla.org installed.
ensureBuiltinExtension: amazon@search.mozilla.org
installExtensionEngine: amazon@search.mozilla.org
addEnginesFromExtension: installing locale: amazon@search.mozilla.org:france
ensureBuiltinExtension: amazon@search.mozilla.org installed.
ensureBuiltinExtension: ddg@search.mozilla.org
installExtensionEngine: ddg@search.mozilla.org
addEnginesFromExtension: installing locale: ddg@search.mozilla.org:default
ensureBuiltinExtension: ddg@search.mozilla.org installed.
ensureBuiltinExtension: ebay@search.mozilla.org
installExtensionEngine: ebay@search.mozilla.org
addEnginesFromExtension: installing locale: ebay@search.mozilla.org:fr
SearchService.init 2
ensureBuiltinExtension: ebay@search.mozilla.org installed.
ensureBuiltinExtension: qwant@search.mozilla.org
installExtensionEngine: qwant@search.mozilla.org
addEnginesFromExtension: installing locale: qwant@search.mozilla.org:default
ensureBuiltinExtension: qwant@search.mozilla.org installed.
ensureBuiltinExtension: wikipedia@search.mozilla.org
installExtensionEngine: wikipedia@search.mozilla.org
addEnginesFromExtension: installing locale: wikipedia@search.mozilla.org:fr
ensureBuiltinExtension: wikipedia@search.mozilla.org installed.
SearchService.init
SearchService.init
Unchecked lastError value: Error: ID already exists: contextPlus-Google Search ExtensionCommon.jsm:679

Ok, sorry, but accessing those logs is really painful, looks like filtering was not a good idea:

SearchService.init
_init start
UTM:SVC TimerManager:registerTimer - timerID: browser-cleanup-thumbnails interval: 3600
SearchService.init
_loadEngines: start
_findEngines: looking for engines in JARs
_parseListJSON: ignoring visibleDefaultEngines value because amazondotcom is not in the jar engines we have found
_loadEngines: loading - google-b-d,bing,amazon-france,ddg,ebay-fr,qwant,wikipedia-fr
_loadEngines: Absent or outdated cache. Loading engines from disk.
ensureBuiltinExtension: google@search.mozilla.org
installExtensionEngine: google@search.mozilla.org
addEnginesFromExtension: installing locale: google@search.mozilla.org:b-d
SearchService.init
addEngineWithDetails: Adding "Google".
_setIcon: Setting icon url "moz-extension://29183b2f-3775-4240-a923-07e1c06fc875/favicon.ico" for engine "Google".
_addEngineToStore: Adding engine: "Google"
ensureBuiltinExtension: google@search.mozilla.org installed.
ensureBuiltinExtension: bing@search.mozilla.org
installExtensionEngine: bing@search.mozilla.org
addEnginesFromExtension: installing locale: bing@search.mozilla.org:default
addEngineWithDetails: Adding "Bing".
_setIcon: Setting icon url "moz-extension://1791bb80-ba15-46dc-842c-5fea070b8c31/favicon.ico" for engine "Bing".
_addEngineToStore: Adding engine: "Bing"
ensureBuiltinExtension: bing@search.mozilla.org installed.
ensureBuiltinExtension: amazon@search.mozilla.org
installExtensionEngine: amazon@search.mozilla.org
addEnginesFromExtension: installing locale: amazon@search.mozilla.org:france
addEngineWithDetails: Adding "Amazon.fr".
_setIcon: Setting icon url "moz-extension://a33d2333-0ba8-4642-ab73-45a6c6afec02/favicon.ico" for engine "Amazon.fr".
_addEngineToStore: Adding engine: "Amazon.fr"
ensureBuiltinExtension: amazon@search.mozilla.org installed.
ensureBuiltinExtension: ddg@search.mozilla.org
installExtensionEngine: ddg@search.mozilla.org
addEnginesFromExtension: installing locale: ddg@search.mozilla.org:default
addEngineWithDetails: Adding "DuckDuckGo".
_setIcon: Setting icon url "moz-extension://b3a623b5-297d-44ac-b93b-55ffc7d5363b/favicon.ico" for engine "DuckDuckGo".
_addEngineToStore: Adding engine: "DuckDuckGo"
ensureBuiltinExtension: ddg@search.mozilla.org installed.
ensureBuiltinExtension: ebay@search.mozilla.org
installExtensionEngine: ebay@search.mozilla.org
addEnginesFromExtension: installing locale: ebay@search.mozilla.org:fr
SearchService.init 2
addEngineWithDetails: Adding "eBay".
_setIcon: Setting icon url "moz-extension://c181c795-e72b-4670-bfb5-36c5d2d646e4/favicon.ico" for engine "eBay".
_addEngineToStore: Adding engine: "eBay"
ensureBuiltinExtension: ebay@search.mozilla.org installed.
ensureBuiltinExtension: qwant@search.mozilla.org
installExtensionEngine: qwant@search.mozilla.org
addEnginesFromExtension: installing locale: qwant@search.mozilla.org:default
addEngineWithDetails: Adding "Qwant".
_setIcon: Setting icon url "moz-extension://122ef87d-d46a-4dd4-bccf-86f076891048/favicon.ico" for engine "Qwant".
_addEngineToStore: Adding engine: "Qwant"
ensureBuiltinExtension: qwant@search.mozilla.org installed.
ensureBuiltinExtension: wikipedia@search.mozilla.org
installExtensionEngine: wikipedia@search.mozilla.org
addEnginesFromExtension: installing locale: wikipedia@search.mozilla.org:fr
_handleIgnoreListUpdated
UTM:SVC TimerManager:registerTimer - timerID: recipe-client-addon-run interval: 21600
addEngineWithDetails: Adding "Wikipédia (fr)".
_setIcon: Setting icon url "moz-extension://8fb15a7e-10af-4ae1-a106-57f0a13df55a/favicon.ico" for engine "Wikipédia (fr)".
_addEngineToStore: Adding engine: "Wikipédia (fr)"
ensureBuiltinExtension: wikipedia@search.mozilla.org installed.
_loadEngines: loading 1 engines reported by AddonManager startup
installExtensionEngine: French-GC@grammalecte.net
addEnginesFromExtension: installing locale: French-GC@grammalecte.net:default
addEngineWithDetails: Adding "Grammalecte".
SearchService.init
SearchService.init
loadFile: moz-extension://d1d1aa75-b947-4180-ad36-645918242aa0//grammalecte/fr/conj_data.json helpers.js:31:25
loadFile: moz-extension://d1d1aa75-b947-4180-ad36-645918242aa0//grammalecte/fr/phonet_data.json helpers.js:31:25
loadFile: moz-extension://d1d1aa75-b947-4180-ad36-645918242aa0//grammalecte/fr/mfsp_data.json helpers.js:31:25
loadFile: moz-extension://d1d1aa75-b947-4180-ad36-645918242aa0/grammalecte/graphspell/_dictionaries/fr-allvars.json helpers.js:31:25
loadFile: moz-extension://d1d1aa75-b947-4180-ad36-645918242aa0//grammalecte/fr/locutions_data.json helpers.js:31:25

It looks like it's triggered by Grammalecte WebExtension.

So, as reported in comment 8, disabling grammalecte extension ""solves"" the issue. I know that :usul who is also affected is also a user of Grammalecte.

Flags: needinfo?(standard8)
Component: New Tab Page → Search

Thank you for the information. I suspect this might happen for any installed WebExtension that extends search, but I haven't checked.

Dale: Here's a full extension + add-on log after starting up latest nightly after the STRs below. The last SearchService.init and the error are from when I start typing in the address bar.

STR:

  1. Create a new profile on Firefox 67.
  2. Start the new profile on 67, and install the Grammalecte extension
  3. (In my case, I turned on browser.search.log and extensions.logging.enabled at this stage).
  4. Close the 67 profile.
  5. Open the profile in latest Firefox nightly

Expected results

  • Everything works

Actual Results

  • New tab page, url bar autocomplete are broken.
Flags: needinfo?(standard8) → needinfo?(dharvey)

Yeh can see whats up here

Assignee: nobody → dharvey
Status: NEW → ASSIGNED
Flags: needinfo?(dharvey)
Attachment #9069523 - Attachment description: Bug 1556424 - Dont await init() on init() installed engines → Bug 1556424 - Dont await init() on init() installed engines. r?Standard8
Priority: -- → P1
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/25b1ee5ee458
Dont await init() on init() installed engines. r=Standard8
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Duplicate of this bug: 1556714
Duplicate of this bug: 1557253

Bug 1552559 is tracking+ for 68, so I assume we want this to be on the radar as well.

Hi Dale, please request uplift for Beta68 if you think it's worth shipping this fix in 68.

Flags: needinfo?(dharvey)

Cheers, included in https://bugzilla.mozilla.org/show_bug.cgi?id=1552559 uplift request

Flags: needinfo?(dharvey)

Comment on attachment 9069523 [details]
Bug 1556424 - Dont await init() on init() installed engines. r?Standard8

followup fix for another change going in 68.0b10

Attachment #9069523 - Flags: approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Verified - Fixed on latest Beta 68.0b10 (64-bit) and Nightly 69.0a1 (2019-06-13) on Windows 10 x64.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Iteration: --- → 69.3 - Jun 10 - 23
Points: --- → 3
You need to log in before you can comment on or make changes to this bug.