Enable MathML in Mozilla builds for the Mac

RESOLVED FIXED

Status

()

--
blocker
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: tague, Assigned: rbs)

Tracking

({platform-parity})

Trunk
PowerPC
All
platform-parity
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Using a build from the tree (7/3/2002), Mac OS X is not rendering MathML correctly.

1) If you look at the roots and the det's, the "container" objects are not being
correctly rendered around the things they contain

2) operators like X and = are not being rendered in the appropriate position
relative to the other elements in the equation
(Reporter)

Comment 1

16 years ago
http://www.lag.net/~tague/mathml.png <== screenshot of rendering problem

Comment 2

16 years ago
Mac OS X currently does not support Math ML...

See http://www.mozilla.org/projects/mathml/enable.html

Alas no specific bug exist that states Math ML does not work on Mac's. I would
suggest the summary be changed to 'Enable MathML on Mac OS X'.

BTW this bug depends on bug 74821 and bug 107146

Comment 3

16 years ago
So let it be done.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Depends on: 74821, 107146
Ever confirmed: true
Summary: Rendering problems with MathML on Mac OS X → Enable MathML in Mozilla builds for Mac OS X

Comment 4

16 years ago
Maybe the severity should be upped since most (all?) platforms have MathML...
not to mention adding MathML would be adding more standards support to Mozilla.

I think it should at least have normal severity.
(Assignee)

Comment 5

16 years ago
Bumping severity to blocker. 

The action is going on in bug 74821. If you have a build and can try things out,
go straight to that bug to lend your help...
Severity: enhancement → blocker
(Assignee)

Updated

16 years ago
OS: MacOS X → All

Comment 6

16 years ago
I don't think this is a blocker...

Comment 7

16 years ago
If Win and Unix have MathML, then this should have the pp keyword.
Keywords: pp
(Assignee)

Comment 8

16 years ago
Created attachment 91293 [details] [diff] [review]
patch to turn on MathML by default on the Mac
(Assignee)

Updated

16 years ago
Attachment #91293 - Attachment description: patch to turn on MathML by default → patch to turn on MathML by default on the Mac

Updated

16 years ago
Keywords: patch, review

Comment 9

16 years ago
Comment on attachment 91293 [details] [diff] [review]
patch to turn on MathML by default on the Mac

sr=sfraser
Attachment #91293 - Flags: superreview+

Comment 10

16 years ago
Peterv, can you please r= the patch in attachment #91293 [details] [diff] [review]?
Is that all what is needed in order to get mathml in OSX builds ?
Comment on attachment 91293 [details] [diff] [review]
patch to turn on MathML by default on the Mac

r=peterv. That should be all that's needed (and MathML still builds, I've had
it on in my build for a while now).
Attachment #91293 - Flags: review+

Comment 12

16 years ago
Comment on attachment 91293 [details] [diff] [review]
patch to turn on MathML by default on the Mac

a=asa (on behalf of drivers) for checkin to 1.1
Attachment #91293 - Flags: approval+

Comment 13

16 years ago
Thanks to mention here (is this appropriate) when it is expected to be in a
nightly build.
(Assignee)

Comment 14

16 years ago
Checked in on the trunk.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Summary: Enable MathML in Mozilla builds for Mac OS X → Enable MathML in Mozilla builds for the Mac

Comment 15

16 years ago
First let me thank everyone about it. It's really nice to see this happening.

But, hey, is this bug already closed ?

At least the font-encoding (uvcmath, right?) thingie doesn't seem to be finished
in today's nighlty. At least today's Markup-of-the-week (the black-scholes
equation today) is definitely corrupted.
I had a message saying the symbol font was missing except it's not missing (it
is indeed standard, but not standard encoding I think).

It would be nice if someone would put instructions on how to cvs-checkout just
this bit and possibly have it run without compiling Mozilla (which never worked
on my dual-g4-450).

Updated

16 years ago
Blocks: 161048

Updated

16 years ago
Blocks: 160001
You need to log in before you can comment on or make changes to this bug.