Closed Bug 1560692 Opened 8 months ago Closed 8 months ago

TEST-UNEXPECTED-FAIL | chrome/test/unit/test_no_remote_registration.js when run in Thunderbird environment

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 69.0

People

(Reporter: jorgk-bmo, Unassigned)

References

(Regression)

Details

(Whiteboard: [Thunderbird-testfailure: X all])

Attachments

(1 file)

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2901d32eddaa6accd04b30725c7307338e&tochange=99f1b315fa89db68ef3e7f8875bbd0a4b8

Looks like this was caused by:
07ced2dfb3b476391cbe6eb3065deba556dc3da8 Nika Layzell — Bug 1560399 - Propagate remote type selection into subframes with Fission, r=farre

I'll confirm via local backout in a minute.

Attached file run.log

Here's a log of running the test locally, amongst other things it says:

 0:01.31 INFO "CONSOLE_MESSAGE: (error) [JavaScript Error: "NS_NOINTERFACE: " {file: "c:/mozilla-source/comm-central/obj-x86_64-pc-mingw32/_tests/xpcshell/chrome/test/unit/test_no_remote_registration.js" line: 94}]"
 0:01.31 INFO "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "During chrome registration, unable to create URI 'moz-protocol-local-resource://foo/'." {file: "file:///c:/mozilla-source/comm-central/obj-x86_64-pc-mingw32/_tests/xpcshell/chrome/test/unit/data/test_no_remote_registration.manifest" line: 32}]"
 0:01.31 INFO "CONSOLE_MESSAGE: (info) No chrome package registered for chrome://moz-protocol-ui-resource/content/moz-protocol-ui-resource.xul"

Looking at the range again, there's also:
7e01c4d1cddcbbd4375fbd8b8909249b9ecb4eb6 Nika Layzell — Bug 1560148 - Make fission.autostart pref visible, r=farre

Oops, this was caused by bug 1555633, I'll fix it via a backout there. Apologies about the noise.

Status: NEW → RESOLVED
Closed: 8 months ago
Regressed by: 1555633
No longer regressed by: 1560399
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 69.0
You need to log in before you can comment on or make changes to this bug.