Closed Bug 1561950 Opened 4 months ago Closed 4 months ago

Lock fission.autostart on beta and release

Categories

(Core :: DOM: Content Processes, defect, major)

defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox68 blocking verified
firefox69 --- verified

People

(Reporter: mccr8, Assigned: mccr8)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Fission is not in a good state to enable on beta and release, and there is at least one reason we really don't want anybody to enable it there, so disallow it there by using lockPref.

I was worried about this causing tests to fail on beta, but Nika said that the way that Fission prefs are enabled for individual tests won't be affected.

It isn't ready to be enabled yet, and right now it can cause URIs to
be leaked to telemetry.

Comment on attachment 9074572 [details]
Bug 1561950 - Lock fission.autostart on beta and release.

Beta/Release Uplift Approval Request

  • User impact if declined: See Bug 1560990.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This simply makes it so that a nonstandard pref setting is ignored. The behavior is pretty broken on 68 anyways, so it isn't likely anybody is going to be using it for much. (This wasn't verified in Nightly, but the patch does not actually change behavior on Nightly, only on Beta and Release. I did a try push with the pref locked, against trunk, and it was okay.)
  • String changes made/needed: none
Attachment #9074572 - Flags: approval-mozilla-beta?

Locally, I checked the behavior of the pref locking without the BETA RELEASE guard. First, I made it so the pref wasn't locked, set the pref to true, and checked that Fission was running. Then I changed all.js to lock the pref, then loaded Firefox and confirmed that the pref was locked and Fission wasn't being used. Then I changed it back, and confirmed that Fission was running again. It looks like there's also various testing of pref locking in the tree.

Pushed by amccreight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9827057d4a86
Lock fission.autostart on beta and release. r=nika,njn
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Comment on attachment 9074572 [details]
Bug 1561950 - Lock fission.autostart on beta and release.

Ensures that Fission isn't enabled on 68 even when the pref is manually set. Approved for 68rc1. I do think that we should have QA verify this, however.

Attachment #9074572 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+

(In reply to Ryan VanderMeulen [:RyanVM] from comment #7)

Ensures that Fission isn't enabled on 68 even when the pref is manually set. Approved for 68rc1. I do think that we should have QA verify this, however.

Seems like a good idea. I'm not sure what the best way to verify it in 68 is. You can easily check that you aren't allowed to set fission.autostart to true in about:config. Maybe that's enough.

Yeah, I figured just making sure that the pref is non-functional would suffice.

This issue is verified fixed using Firefox 68.0 and Firefox 69.0b1 on the following OSes: Windows 10x64, Windows 7x86, mac OS10.14 and Ubuntu 18.04x64

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.