Closed Bug 1563631 Opened 3 months ago Closed 2 months ago

[Mac 10.15] Firefox 68 and 67.0.2+ cannot be opened on macOS 10.15 Beta

Categories

(Core :: Widget: Cocoa, defect, P2, blocker)

67 Branch
Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1471004
Tracking Status
firefox67 --- affected
firefox68 --- affected
firefox69 --- unaffected

People

(Reporter: macdaddy, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.0 Safari/605.1.15

Steps to reproduce:

I tried to update Firefox and have even completely deleted it, downloaded fresh and the OS will not let it run

Actual results:

I get the following message -
“Firefox Software Update.app” can’t be opened because Apple cannot check it for malicious software.
This software needs to be updated. Contact the developer for more information.

Expected results:

I should be able to run the app

I tested this on Mac OS X 10.15 Beta3 (Beta (19A501i) and I can reproduce this with FF Release 67.0.4. The issue is not reproducible with Beta 68 and Nightly 69.0a1(2019-07-07).
Also tested on firefox/candidates/68.0-candidates/build3/mac/en-US/ (http://archive.mozilla.org/pub/firefox/candidates/68.0-candidates/build3/mac/en-US/) the issue is reproducible.
We tested on 2 different iMacs and the issue is reproducible.
This is a regression, on Mac OS X 10.15 Beta 2 the issue is not reproducible after the OS is updated to Beta 3 the issue is there.

Macdaddy please download Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.

Blocks: catalina
Severity: normal → blocker
Status: UNCONFIRMED → NEW
Component: Untriaged → Widget: Cocoa
Ever confirmed: true
Flags: needinfo?(macdaddy)
OS: Unspecified → macOS
Product: Firefox → Core
Summary: Cannot be opened on macOS 10.15 Beta 3 → [Mac 10.15] Cannot be opened on macOS 10.15 Beta 3
Summary: [Mac 10.15] Cannot be opened on macOS 10.15 Beta 3 → [Mac 10.15] Firefox cannot be opened on macOS 10.15 Beta 3

Haik, is this the same issue that you just fixed?

Flags: needinfo?(haftandilian)
Priority: -- → P2

I just tried reproducing on my machine running (19A501i). After fiddling with the security settings and allowing Firefox by using the "Open Anyway" dialog, I was able to launch Beta 3.

(In reply to Stephen A Pohl [:spohl] from comment #2)

Haik, is this the same issue that you just fixed?

Yes, this definitely sounds like a duplicate of bug 1556733 where updates fail on 10.15 Beta and after the failed update, Firefox can not be launched. Bug 1556733 is expected to be is reproducible on 67 at this time.

I'm editing this comment to correct what I said above. See comment 5. I read this the original description as being related to the updater, which sounded like bug 1556733. This does not appear to be a duplicate. More debugging required.

Status: NEW → RESOLVED
Closed: 2 months ago
Flags: needinfo?(haftandilian)
Resolution: --- → DUPLICATE
Duplicate of bug: 1556733
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

As a workaround, please try right-clicking on Firefox and selecting Open.

This is most likely due to Build 68 not being Notarized. This would affect 68 and not 67 because macOS 10.15 uses the application build date to determine which applications are required to be Notarized in order to launch. According to the WWDC presentation[1] around 8:00, all software "signed on built after June 1st" must be Notarized.

We have enabled Notarization on build 69 and plan to uplift this at some point in the future.

  1. https://developer.apple.com/videos/play/wwdc2019/701/
See Also: → 1471004

To summarize status for various versions:

  • 67.0 was not notarized. The last release build before June 1st was 67.0.1, which would explain the result with 67.0.4 in comment #1
  • 68.0 is not notarized right now. The last beta build before June 1st was 68.0b6, which may not agree with comment #1, depends which beta was tested
  • 69.0 was notarized from the 20190626215508 Nightly, 69.0b3 should be released within the next day or so

To be clear I downloaded and installed Beta 68.0b14 which is not notarized per previous comments and build 69 is not yet available. One workaround for now is to open the package and remove the updater app. This allows Firefox to launch but of course it cannot do an update check. I will gladly wait or version 69 beta to continue testing. Right-clicking, selecting Open still fails as it is the updater app that is being rejected.

Flags: needinfo?(macdaddy)

Until we uplift Notarization to Firefox 68 (bug 1471004) I think the best workaround for running Firefox on the macOS 10.15 Betas is to use Firefox Beta 69 in a new profile.

Summary: [Mac 10.15] Firefox cannot be opened on macOS 10.15 Beta 3 → [Mac 10.15] Firefox 68 and 67.0.2+ cannot be opened on macOS 10.15 Beta
Duplicate of this bug: 1565348
Duplicate of this bug: 1566432

Duplicate of this bug 1565631

I'm marking this bug as a duplicate of bug 1471004 which enabled Notarization. Bug 1471004 has now been uplifted to Firefox 68.0.1.

Users running macOS 10.15 Beta that have already installed Firefox 68.0.0 or Firefox 67.0.2+ will have to re-download Firefox to get 68.0.1.

Users running macOS 10.15 Beta that download Firefox will get 68.0.1 and it should launch as normal on macOS 10.15.

Users that installed 68.0.1 before upgrading to macOS 10.15 Beta should not be affected.

Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1471004
Duplicate of this bug: 1567646
You need to log in before you can comment on or make changes to this bug.