Closed Bug 1565133 Opened 5 months ago Closed 3 months ago

Picture in Picture window is empty on Wayland

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

69 Branch
Desktop
Linux
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: emmybaylove, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Issue present in Gnome Wayland, Firefox 69+, with MOZ_USE_WAYLAND enabled.

The Picture in Picture window is empty and transparent, displaying only the video controls and the outline. Audio continues playing as normal, and the video can still be paused or sent back into its tab.

Attached image screenshot.png
Blocks: 1532677

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task

Maybe related to bug 1532096? Mike?

Type: task → defect
Flags: needinfo?(mconley)

Thanks! Unsure ... I haven't done too much digging into Linux support yet. I've been surprised to hear that it already works well for some folks, but yeah - there are variations here that are going to need working out. P3'ing for now until we can get to it (after macOS).

Flags: needinfo?(mconley)
Priority: -- → P3

That works for me on latest nightly + Fedora 30 + mutter (gnome-shell). Can you try latest nightly and which compositor do you use?
Thanks.

Flags: needinfo?(emmybaylove)

This issue hasn't been present for me in recent nightlies either; haven't been able to reproduce it on Gnome 3.32 or 3.34.

Flags: needinfo?(emmybaylove)
Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.