Closed Bug 1565254 Opened 1 year ago Closed 1 year ago

Old about:config warning title lacks contrast in dark mode

Categories

(Toolkit :: Themes, defect, P3)

69 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr68 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- verified

People

(Reporter: ke5trel, Assigned: ke5trel)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(2 files)

Attached image Invisible warning title

STR:

  1. Use a dark system theme or set ui.systemUsesDarkTheme = 1.
  2. Make sure general.warnOnAboutConfig = true.
  3. Go to the old about:config page chrome://global/content/config.xul.

The warning title is barely readable.

This blocks enabling the in-content dark mode since old about:config is still on by default on release/beta.

Blocks: 1565051

Thanks for taking this on Kestrel :)

Priority: -- → P3
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f3804754bb79
Old about:config warning title should inherit text color for dark mode compatibility r=dao
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
QA Whiteboard: [good first verify]
Duplicate of this bug: 1580955

Managed to reproduce the issue on an affected build 69.0a1 (2019-05-20, build 20190520215528), using the steps to reproduce from the description, on Windows 10x64.

The issue is no longer reproducible on Firefox 72 (build 20191230161130). Tests were performed under Windows 10x64.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.