Closed Bug 1565910 Opened 5 months ago Closed 5 months ago

Phabricator's borders are corrupt again.

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 + fixed
firefox70 + fixed

People

(Reporter: emilio, Assigned: nical)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: correctness, regression)

Attachments

(4 files)

This is a recent-ish regression. Screenshot incoming. I also have a standalone (unreduced, though) test-case.

Attached file Testcase

Debian Testing, KDE, X11, Macbook Pro, Intel Iris 6100 (Broadwell GT3)
I see it at 110% zoom.

Also reproducible on Win10, Radeon RX480, 2560x1440.
[Tracking Requested - why for this release]: Win10 without battery is affected by default (Nvidia, AMD, Intel).

Has Regression Range: --- → yes
Has STR: --- → yes
OS: Unspecified → All
Hardware: Unspecified → All

(Related: If bug 1558135 touched borders, it might be the cause I don't see bug 1555977 as often as before: Sometimes there is still some blinking, but only for a short moment. I don't know.)

Assignee: nobody → nical.bugzilla
Flags: needinfo?(nical.bugzilla)
See Also: → 1566014
Attached file Reduced testcase
See Also: → 1566099
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f86fb2490cfa
Preserve batch features when merging batches. r=gw
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Please nominate this for Beta approval when you get a chance.

Flags: needinfo?(nical.bugzilla)

Comment on attachment 9078157 [details]
Bug 1565910 - Preserve batch features when merging batches. r=gw

Beta/Release Uplift Approval Request

  • User impact if declined: Incorrect rendering of dashed/dotted borders under certain circumstances.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Very simple patch.
  • String changes made/needed: None.
Flags: needinfo?(nical.bugzilla)
Attachment #9078157 - Flags: approval-mozilla-beta?

Comment on attachment 9078157 [details]
Bug 1565910 - Preserve batch features when merging batches. r=gw

Fixes incorrect rendering of dashed/dotted borders under certain circumstances when WebRender is enabled. Approved for 69.0b6.

Attachment #9078157 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
See Also: 1566014
Duplicate of this bug: 1566014
Regressions: 1568698
You need to log in before you can comment on or make changes to this bug.